Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

FreeNas-TrueNAS upgrade issues

Western Digital Drives - The Preferred Drives of FreeNAS and TrueNAS CORE

Nsganser

Newbie
Joined
Oct 23, 2020
Messages
3
Hello!
I've recently upgraded to TrueNAS, However, I've come to regret updating to the newest version.

Long story short, I upgraded from Freeness 11.3 to TrueNAS Core, After upgrading I was having issues accessing my pool. So I was able to edit the ACL to have access to it, As well as the account I use for my Plex server. Now it is showing I don't have any files in my PLEX folder (where I store downloads, tv, and movies). At the same time I also don't have any files for multiple things outside of just plex. My Animation Mentor backups and notes, Personal project files and videos, etc. Unfortunately I didn't have snapshots enabled. I think its weird that these files are "missing", but the folders are all still there, and some of my files are still there. Maybe there is an issue with permissions still? I've been using Freeness for a while now, but still kind ow new to it so I'm not super advanced, Hopefully this helps and I can add more if needed. Am I just screwed out of this data? Thanks in advance!

System:
CPU: AMD A10-6800K APU
Ram: 16GB DDR3
SSD (OS): 120GB SanDisk SSD
HDDS: 5x 3TB SEAGATE ST33000650SS HDD (Configured in ZFS2)
NIC: Intel X520

I attached the files for the pool if it helps
 

Attachments

Nsganser

Newbie
Joined
Oct 23, 2020
Messages
3
Ok! So I've been digging around to see if its actually gone or not, I ran "ls -all -R > /tmp/fileslist.ext" in the folders that are empty. Luckily the files show up in the list (Whew!). So Im guessing the issue is something with permissions. What is weird is that those files are hidden for both by Plex and Admin users, But in some other folders I can access and still see files.
 

Nsganser

Newbie
Joined
Oct 23, 2020
Messages
3
Aha! Nevermind! I figured it out! The user groups were set wrong. I set the primary group as wheel, then auxiliary is set to builtin_users. Now I can go in and the files are showing up! :grin:
 
Top