• Currently using VMware at work? We want to hear from you.

    Thinking of making a switch from VMware? We'd love to hear your thoughts and feedback about which hypervisor you have been researching or already using. Click here to vote and share your thoughts! You can vote HERE!

FreeNAS dead after starting (auto-scheduled) scrub

Status
Not open for further replies.

asari

Cadet
Joined
Nov 28, 2011
Messages
5
Hi,

My FreeNAS server's uptime became 30 days, and automatic zpool scrub started on it (daily email sent to me), then somehow stopped in a few minutes (no ping/ssh/cifs response from it; my Nagios emailed me and complained that some mountpoints were invalid).

I woke up and found it stopped, so I pressed the power button twice and it restarted, restarted zpool scrub too, it stopped again in a few minutes.
I pressed the power button again and it restarts, then I logged into it via SSH, did `zpool scrub -s tank0`, and now it seems to work healthy.

Perhaps it will stop again tomorrow at 3:00. How can I get workaround on it (like temporarily disabling automated scrub)? Or, how can I troubleshoot (like turning on logging any messages)?

Sorry for my poor English, thanks in advance.

FreeNAS Build: FreeNAS-8.0.2-RELEASE-amd64 (8288)
Platform: Intel(R) Core(TM) i3 CPU 530 @ 2.93GHz
Memory: 6057MB
OS Version: FreeBSD 8.2-RELEASE-p3

Hardware: HP ML 110 G6 with 6 HDDs
 

William Grzybowski

Wizard
iXsystems
Joined
May 27, 2011
Messages
1,740
As a workaround for now you can comment the line "daily_scrub_zfs_enable="YES"" in /conf/base/etc/periodic.conf

mount -uw / - to mount root as read-write
 

asari

Cadet
Joined
Nov 28, 2011
Messages
5
As a workaround for now you can comment the line "daily_scrub_zfs_enable="YES"" in /conf/base/etc/periodic.conf

mount -uw / - to mount root as read-write

Thanks! I executed following commands; let me see what the daily mail will say at next 3:00 a.m.

# mount -uw /
# nano -w /conf/base/etc/periodic.conf # turn daily_scrub_zfs_enable to "NO"
# mount -ur / # this took a while


( just overwrote "YES" with "NO", because I didn't know how to comment it out...
which style of comment is available? "#", ";" or "//" ....? )
 

asari

Cadet
Joined
Nov 28, 2011
Messages
5
I received a mail from my FreeNAS server today:

Scrubbing of zfs pools:
skipping scrubbing of pool 'tank0':
last scrubbing is 3 days ago, threshold is set to 30 days
skipping scrubbing of pool 'tank1':
last scrubbing is 29 days ago, threshold is set to 30 days

It seems that the auto-scrub might be still scheduled. Let's wait for tomorrow and see if auto-scrub is really disabled.
 

asari

Cadet
Joined
Nov 28, 2011
Messages
5
Although daily_scrub_zfs_enable is set to "NO", auto-scrub was not canceled and my FreeNAS died again today. Sad, I did `zpool scrub -s` manually.

Perhaps it dies because of hardware problem (like short of electricity), but how can I diagnose it? I can't see any log file in /var/log after restart...
 
Status
Not open for further replies.
Top