FreeNAS being flaky when connecting to my (Active Directory) domain

Not open for further replies.


Nov 12, 2013
Had FreeNAS working pretty perfectly with my domain controller. My domain controller runs on Win2012r2 in a VM on another machine. Had some trouble with the hypervisor and the VM itself, after which FreeNAS was giving LDAP errors when trying to connect. But logins on another Windows workstation were also failing, so I relegated the problem to the domain controller and not FreeNAS.

So I built a new domain controller (in a fresh VM), spun up a fresh domain, and successfully connected my Windows machines to it.

But when I first tried to connect FreeNAS to the new domain, it would say 'Please wait...' but then eventually seem like it finished. But if I refreshed the GUI, the Enable checkbox would then be unchecked.

I tried a few more times and inexplicably the checkmark stuck and seems to survive a reboot

But if I run *net ads join* and *wbinfo -u* I get these results.

None of the Active Directory users are imported. Yet the AD groups come up if I run *wbinfo -g*. Dunno if they are somehow cached from the previous DC?

Not sure what my next step should be...

EDIT: I ran these commands and they all seemed to work except service ix-activedirectory start produced a similar error to when I run net ads join.
Last edited:
Not open for further replies.