Register for the iXsystems Community to get an ad-free experience

Connexion internet et au serveur depuis "l'exterieur"

Archipuck75

Cadet
Joined
Sep 19, 2022
Messages
2
Bonjour,

Complètement débutante en matière de NAS, je me suis lancée dans l'installation de Truenas via un tutoriel de Techworks (en anglais...) sur Youtube. J'ai un serveur opérationnel quand je suis chez moi et j'arrive à m'y connecter depuis un PC extérieur via OpenVPN. Mon problème est le suivant : quand je me connecte via openVPN depuis l'exterieur j'accède bien à mon serveur mais parallèlement je ne peux plus surfer sur internet, seul le trafic de données avec mon serveur fonctionne.
Quelqu'un peut-il m'éclairer sur le sujet?

Cordialement.
 

Pitfrr

Guru
Joined
Feb 10, 2014
Messages
1,243
Bonjour,

J'ai l'impression que cela pourrait être lié à une mauvaise configuration de la passerelle dans les paramètres réseaux?
Il faudrait voir au niveau des paramètres du serveur VPN s'il y a pas une option concernant la passerelle.
Je ne sais pas si tu utilises le service OpenVPN intégré dans TrueNAS ou si tu as un autre serveur VPN séparé sur ton réseau. Je ne connais pas bien la configuration du service OpenVPN pour TrueNAS car dans mon cas, j'utilise un serveur séparé...

Ca serait bien d'avoir un peu plus de détails sur ta configuration (matérielle, réseau, logicielle...) et le lien vers la vidéo youtube peut aider aussi (pour voir comment est faite la configuration).
 

Archipuck75

Cadet
Joined
Sep 19, 2022
Messages
2
Bonjour,

Merci pour ta réponse, je pense aussi que ça vient de là mais le peu que j'ai essayé de faire là où je voyais écrit "gateway" n'a pas résolu mon problème.
J'utilise le service OpenVPN intégré dans TrueNAS.
En ce qui concerne ma configuration , j'ai récupéré une ancienne station de travail HP Z220 : Intel(R) Xeon(R) CPU E3-1245 V2 @ 3.40GHz, j'ai deux HD de 3TB en miroir, TrueNAS-12.0-U6.1, 16GB RAM, Truenas est installé sur un SSD et j'ai un autre SSD en cache.
J'ai un routeur Orbi derrière ma livebox pour avoir un réseau wifi qui passe partout dans la maison et cela m'a pris un peu de temps pour gérer les adresses IP à indiquer au bon endroit...
Ci-après le lien vers la video que j'ai suivi pour l'installation : https://youtu.be/YEkfW4aC9Rk . Il y a une deuxième vidéo qui doit, je pense, répondre à ma question mais je ne comprends pas tout et ne veut pas faire n'importe quoi...: https://youtu.be/it0HdDiutIE.
 

Pitfrr

Guru
Joined
Feb 10, 2014
Messages
1,243
Dans la deuxième video, la connexion internet fonctionne déjà en fait. C'est à dire que dès le début de la vidéo, il montre comment, lorsque la connexion VPN est activée, le traffic internet passe par le serveur VPN. Et le sujet de la vidéo c'est comment peut-on limiter l'accès au réseau local tout en conservant la connexion internet pour les clients VPN (j'ai pas tout regardé non plus mais juste le début).

En fait ça se trouve surtout dans la première vidéo, vers 15:45 pour la configuration du réseau. J'imagine que cette partie là est bonne pour toi car tu dis que tu peux accéder au réseau local distant.
Par contre, est-ce que la partie suivante est aussi correctement configurée (la partie vers 17:30)? Si tu n'as accès à internet cela peut venir de là.
Il y a ensuite une section sur le tunables, là je maitrise pas trop mais je pense qu'elle est nécessaire pour avoir l'accès internet aussi et il faut qu'elle soit bien configurée (par exemple, il faut que ce soit la bonne interface réseau utilisée).
Je pense que tu as un paramètre qui doit être mal configuré dans ce coin là...

Juste pour être sûr:
- tu as bien adapté les adresses IP selon ta topologie réseau?
- tu dis que tu as un routeur Orbi entre la box et le serveur TrueNAS, est-ce que ça ne te rajoute pas un problème? (un schéma réseau aurait été le bienvenu pour comprendre un peu mieux)
- as-tu adapté l'interface utilisée dans les tunables?


Remarque sur ton matériel:
- tu dis que tu as un SSD pour cache. Vu ta configuration, cela n'est pas vraiment utile. Un cache est utile quand tu as maximisé la RAM, ce qui n'est pas ton cas. En gros, le cache va se rajouter quand tu peux vraiment plus faire autrement. Car oui, un SSD est rapide mais comparé à de la RAM pas vraiment. Donc pour conserver de bonnes performances, on va d'abord maximiser la RAM et après songer à un cache. Dans ton cas, ça pourrait même ralentir tes performances (c'est ce que j'ai lu, je ne parle pas d'expérience car je n'en utilise pas).
 

profwalken

Patron
Joined
Nov 19, 2013
Messages
328
Je suis dans la meme situation, ayant suivi le meme tuto , j'arrive sans soucis à acceder aux machines du Lan distant mais je n'ai plus accès à internet. quand la connexion VPn est active , il n'y a pas d'adresse de passerelle dans la config IP.

Avez vous solutionné ?

Maintenant j'ai fait un changement dans les réglables qui empeche le serveur de demarrer normalement. j'ai changé la carte réseau de igb0 à em0
dans la ligne: natd_interface des reglables.
je ne sais pas comment désactiver cette ligne de reglable sans la console graphique.

Dans le cas le plus défavorable, j'envisage de reinstaller et de remettre une sauvegarde précédente.
 
Last edited:
Top