Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Can’t access FreeNAS web UI on mobile

Western Digital Drives - The Preferred Drives of FreeNAS and TrueNAS CORE

jstockley

Cadet
Joined
Jun 9, 2020
Messages
3
Hello all,

Whenever I try to acess the freeNAS web UI on my iPad or my iPhone I get an error saying: “Connecting to FreeNAS ... Make sure the FreeNAS system is powered on and connected to the network.” but I am able to access the web UI on my macbook Pro. I am also able to ssh into FreeNAS from my iPad. Does anyone know what might be causing this and how to fix it?

Thanks
Jack
 

Attachments

  • 37D0A4DB-0DB0-40D1-B682-3E4241D045F0.png
    37D0A4DB-0DB0-40D1-B682-3E4241D045F0.png
    1.2 MB · Views: 104

sretalla

Hall of Famer
Joined
Jan 1, 2016
Messages
6,617
I just tried it and had success on an iPad.

Maybe you need to clear the browser's cache.
 

jstockley

Cadet
Joined
Jun 9, 2020
Messages
3
Thanks for the suggestion. Sadly that didn't work. I was able to find a workaround. I had to disable the https redirect for the webui. I don't know if there is a bug in freeNAS on with iOS.
 

sretalla

Hall of Famer
Joined
Jan 1, 2016
Messages
6,617
iOS probably enforces certificate checking in Safari (and all other browsers since only Webkit browsers are allowed by apple, so effectively Safari).
 

no_connection

Patron
Joined
Dec 15, 2013
Messages
475
I have gotten that error on normal browser a few times. It loads login then suddenly pretends it can't access FN and you have to reload a few times for the stupid thing to work again. That check needs to be removed since it bricks interfacing with the NAS at times.
 
Top