Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

X520-DA2

Western Digital Drives - The Preferred Drives of FreeNAS and TrueNAS CORE

BlueScreenTT

Member
Joined
Mar 26, 2018
Messages
60
Hej

Får jag dessa att fungera under Freenas11.2
tycker det är svårt att hitta ett bra svar
nån som vet ?

om inte vad skall jag skaffa för att få 10GBE att fungera
Mvh
Thomas
 

Sjöhaga

Member
Joined
Apr 17, 2016
Messages
33
jag kör med såna, inga problem i FreeNAS, är inte nöjd med dem i windows 10 ännu men det är ett annat problem.
Det behövs göras några inställningar för att det ska funka bra i FreeNAS men jag kör i princip rakt av från vad som står 10bge tråden.
 

Robertr

Member
Joined
Sep 22, 2017
Messages
30
Hur funkade det med Chelsio?
Jag har ett par kort (osäker på modellbeteckning) och funderar på att köra ett i FreeNAS för att testa om det blir mer fart än med Intel X520.
Har inte sett så mycket på tuning men har på autotuning.
 

Sjöhaga

Member
Joined
Apr 17, 2016
Messages
33
Den här https://forums.freenas.org/index.php?resources/10-gig-networking-primer.42/ med medföljande tråd är värdefull.Där står i princip allt man behöver veta.
Jag får ut ca 80% av teoretisk max med iperf3 med en pentium G3240 med 10-20% cpulast utan att använda jumboframes så jag är helnöjd. Mina diskar är inte i närheten av att komma upp i den hastigheten :P

Autotuning brukar inte rekommenderas utan utgå ifrån de inställningar som postas i tråden, tror det är nånstans i slutet som där är en bra sammanställning.
 

Robertr

Member
Joined
Sep 22, 2017
Messages
30
Cool. Jag får försöka leta lite där när jag har tid.. det är ju typ 40 sidor.
Annars, om någon har lust att dela med sig vad de har för tuninginställningar med tanke på Intel 10Gb så är jag tacksam. (Har X520.)
 

Sjöhaga

Member
Joined
Apr 17, 2016
Messages
33
det är 19 sidor :D en hel del inaktuellt i början som man kan snabbläsa. Men i princip allt man behöver veta finns där.

Jag kör nästan rakt av på dessa https://forums.freenas.org/index.php?threads/10-gig-networking-primer.25749/post-436620
Inte helt eftersom de är anpassade till mitt system. Man behöver slå upp vad de är så att man vet om man ska öka eller minska, och om värdet ska vara en speciel multipel av nått osv. men det fins bra dokumentation på gogeln.
 

Robertr

Member
Joined
Sep 22, 2017
Messages
30
Nice, ska ta en titt.
 

Robertr

Member
Joined
Sep 22, 2017
Messages
30
Förresten, var de där tuning-inställningarna specifikt för Chelsio eller förnuftiga för Intel X520 också?
Som det är nu får jag bara runt 2,7Gb Client(OSX) -> FreeNAS och runt 6Gb FreeNAS -> Client med iperf3.
 

Robertr

Member
Joined
Sep 22, 2017
Messages
30
Ursäkta att det blev lite mycket tjat här nu... :)
Jag lade in de där tuning-inställningarna men det blev faktiskt bara långsammare.
Förut körde jag DAC mellan arbetsstationen och FreeNAS och då funkade det inte med Jumbo Frames
Nu provade jag det igen (Har installerat en Dell N1124T-ON Switch i helgen) och då blev det fart..
1,15GB / 9,9Gb både upp och ned med iperf3.
Osäker på om den tuningen var nödvändig men om det inte blir några problem så rör jag inget mer.
 

BlueScreenTT

Member
Joined
Mar 26, 2018
Messages
60
Hur funkade det med Chelsio?
Jag har ett par kort (osäker på modellbeteckning) och funderar på att köra ett i FreeNAS för att testa om det blir mer fart än med Intel X520.
Har inte sett så mycket på tuning men har på autotuning.
fungerade skit bra med iperf3 fick jag 9,3 från en windows 10 pro
Chelsio på win 10 pro var inte roligt 3 reinstall med en jäv.. massa Bluescreens men till slut fungerade det utan problem :smile:
 

Sjöhaga

Member
Joined
Apr 17, 2016
Messages
33
Några av inställningarna tror är nödvändiga, större buffertar på några ställen. Men samtidigt så är det ju iom 11.2 en nyare FreeBSD under skalet så det är inte omöjligt att en del defaults är bättre anpassade och då kan det ju vara så att det inte behövs specas i FreeNAS.

Det är ytterligare en anledning till att man behöver läsa på, kolla i sitt eget system vilka värden som finns i systemet innan man stoppar in egna. Annars förstår man ju inte vad som händer och vilka värden som gör vad.

men fort går det :)

x520 har inte orsakat några blåskärmar i windows för mig, däremot en rejäl cpu-last. Jag har fått det bättre nu men det syns fortfarande tydligt att det drar cpu under överföring så jag har mer att jobba med där innan jag blir helt nöjd.
 
Top