Unable to Boot Truenas Scale From SSD or HDD - Works fine on Flash Drive

George K

Mar 16, 2024
Hello all, newbie here,

I snagged a HPE ProLiant Microserver Gen8 before it hit the recycle bin and redirected it to my home office. The vintage is 2016.
Right now it is running Windows Server 2012 R2. I upgraded the ram memory from 4GB to 16GB. It has four 4TB hard drives and it runs great. Of course WS2012R2 has reached end of life so I would like to install Truenas Scale on an SSD as the bool pool. I had problems with TNS and could not get it to boot from a flash drive. I read in these forums to go back to TNS 22.02.0 and it now boots from a flash drive perfectly. Once I have my boot pool created on an SSD I will update to the current version of TNS. So to my troubles, I cannot get TNS 22.02.0 to boot from an SSD or HDD. The creation of the boot drive goes perfectly with out a hitch in all the variations I have tried, but after creation will not boot to TNS. I have tried a Crucial 1TB drive, a PNY 1 TB drive, a WD Slim 1TB HDD drive, and they will not boot.
I have changed the boot order in the BIOS to USB first and HDD second and still no go. Works every time with my flash drive. I have tried MBR and GPT and no go.
I tried to clone my flash drive to the SSD and HDD and no go. I tried to clone the flash drive to the SSD within TNS under settings, boot pool and was unsuccessful.

Any ideas? Help!

Thanks so much, George


Sep 18, 2020
I don't know that system so I'll stick this right up front. It has a RAID (HP Smart Array B120i ) controller which supports RAID 0/1/10 only (apparently no passthrough or JBOD so the system generally will not work with Truenas. I would look for a different system that matches the required specifications ot Truenas.

If you want to hammer away anyway on what you have.
It seems like the HPE MicroServer Gen8 supports UEFI bootloaders, and TrueNAS Scale I believe requires UEFI boot to be configured for the install to complete, so try that. You should put the drive you are setting up as a boot drive on a SATA port inside the system if it is not already and the drive has to be the first drive in the BIOS list I think in order for the system to boot it.


Jun 2, 2016
TrueNAS Scale I believe requires UEFI boot to be configured for the install to complete

Ahh, that explains why I couldn't boot the installer on my potato, but I could upgrade CORE boot USBs