Trying to tune nfs performance for rsync writes

Not open for further replies.


Jan 16, 2018

I am running FreeNAS 9.3 on FreeBSD. here are my system details

CPU: Intel(R) Xeon(R) CPU E5-2603 v3 @ 1.60GHz (1600.03-MHz K8-class CPU)
avail memory = 199432622080 (190193 MB)

I am running on a 10GB connection

cxl0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
media: Ethernet 10Gbase-SR <full-duplex>

I seem to have super slow writes to the server with small files I try to rsync. Bigger files tend to rsync faster than the bunch of .html and .jpg (around 4k).

I am also attaching a screenshot of my nfs settings. I noticed reading some other posts that you can make some changes so that ZIL is set to disabled by using this command zfs set sync=disabled. I am trying to avoid using
this setting because i heard it might be bad for nfs read/writes. Is this true?

Also, how would I able to enable my server to enable other systems that nfs mount onto it to accept changes in the wsize,rsize. My version of FreeNAS is hardcoded to rsize=65536,wsize=65536. Is that because of the version I am using? Do I have to upgrade to a newer version of FreeNAS so that this parameter can change?

Pretty new to this so any advice would be much appreciated


  • Screen Shot 2018-01-16 at 10.38.01 PM.png
    Screen Shot 2018-01-16 at 10.38.01 PM.png
    37.1 KB · Views: 304
Last edited by a moderator:


Did you make any changes that made a difference? Also, have you considered updating to take advantage of underlying OS improvements?
Not open for further replies.