Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Syncthing: GUI unreachable

Western Digital Drives - The Preferred Drives of FreeNAS and TrueNAS CORE

ajdales

Neophyte
Joined
Apr 24, 2015
Messages
7
Hi all,

After several years of lurking on these forums and finding the answers with help of Google I finally hit a problem I couldn't find a solution for.

I have been running my old freenas server since version 9.3 (currently om 11.1) and followed the upgrade path. However because of the new zfs feature flags and a lack of storagespace I deceded to upgrade my E3-1230 with a 5-disk raidZ1 to a D-1521 (11.2-U7) with 3-disk raidZ1's and reinstalling / configuring all my original jails.

Starting with the most important plugin for me: Syncthing
The original install proceded flawless, and both the OLD and NEW server initiated file synchronisation with all my other machines.
However the next day NEW was no longer visible in the GUI on the other machines and the NEW GUI was no longer reachable (neigther through IP:8384 or IP/syncthing/).

Being uable to find a solution to reconnecting to the GUI, and blaming my having changed de DHCP IP to an other adress (unique and on the same subnet) I decided to delete the plugin and reinstall. This did not solve any problems.

After much poking at the jail I figured out 'nginx' is working (I get an error page on IP/syncthing/. However the syncthing service won't start.

If I try to start it manually within the jail I get the following errormessage:
Code:
root@syncthing:/ # service syncthing start
Starting syncthing.
su: /bin/csh: Permission denied
/usr/local/etc/rc.d/syncthing: WARNING: failed to start syncthing


I have already tried several of the steps in this guide: https://vermaden.wordpress.com/2018/08/21/syncthing-on-freebsd/
The 'log' and 'pid' files are in the jail abd the 'syncthing user' has RW rights
Code:
-rwxr-xr-x  1 syncthing  syncthing  0  Jan 29 15:44 /var/run/syncthing.pid
-rwxrwx---+  2 root  wheel   427888 Jun 22   2018 /bin/csh


Does anyone have an idea what is going wrong here?

Thanks André

server config:
Supermicro X10SDV-4C-TLN2F (D-1521)
32GB ECC DDR4 (single module)
Intel optane 16GB as boot
2*WD red 6TB in degraded raidZ1 (only until migration is completed)
 
Last edited:

ajdales

Neophyte
Joined
Apr 24, 2015
Messages
7
Hi all,

I did not find the reason for my problem, But I did manage to solve it.
Considering this is a new server, which has not been put into production (and I still think a little bit like a Windows user) I decided to reinstall FreeNAS. By now 11.3 has reached release status, which I promptly used for my fresh, fresh install.
After rebuilding te basic configuration, I followed the great video by Lawrence Systems and the guide written by Zufallsheld to get the right rights to the “sync” user. And it has been working like a dream.

However I cannot reach the webgui by entering the address, but only through the link provided by the pluginmanager. The installer did use the server ip for the jail ip. I can get into the webgui by using the syncthing port (IP:8384/syncthing/). Is this standard behavoir with the new pluginmanager?

I was used to the DHCP range I gave to the old FreeNAS to hand out to jails.

Thanks again,
André
 
Top