[SOLVED] error: <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed


Mar 2, 2016
So the short version of this story goes like this... I took a week off work back in December of 2017. At that time I started to plan a reinstall complete fresh install of my FreeNAS as well as switching all my jails over to the new iocage jail system on a pair of mirror ssd. I started compiling myself a "how to" with all the steps I needed specific to my setup. As I practiced some of the basic for managing iocage from the CLI I was running FreeNAS in a VM. At that time I believe I was using FreeNAS 11.1 U1 and a jail created by iocage would report freebsd-version = 11.1-RELEASE-p6. ok so far so good. I use FreeNAS at home so its main job is file sharing as well as using jails to run various home multimedia and home automation programs. So at the end of 2017 I have FreeNAS 11.1 U1 installed in a VM and have successfully created jails with iocage. Also I have reinstalled in said jails all my home media/automation and everything is working great in a VM. Unfortunately I ran out of vacation time before I could actually perform the clean install of FreeNAS and deploy my new iocage jail system on my physical server.
Fast forward 3 months and I finally have time to update my server! So fresh install ends being FreeNAS-11.1U2. Install new SSDs and configure them for iocage. At this time freebsd-version = 11.1-RELEASE-p8 as reported from inside a jail. My first jail to reinstall was used for Home Assistant. While the initial pip3 install went off without a hitch I could not get the Z-Wave component to install correctly. I didn't copy the entire error but the bottom line seemed to be related to this error
error: <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:777)

Let the Google begin! I'm basically a newbie that followed some guides and got FreeNAS installed and some jails up and running but I didn't run into any problems. I didn't even know what to begin searching to track this one down! As I worked on this issue with Home Assistant I began reinstalling programs in other jails one of which included GMusicProxy. While some commands like listing an artist or album worked, when I tried to retrieve music from my library I received the same SSL error. I can't even tell you what all I searched and didn't understand 95% of what I read but what finally got everything working was installing "ca_root_nss" in each resective jail.
pkg install ca_root_nss

Not sure if this was covered somewhere but hopefully this helps


Oct 18, 2019
Maybe I'm just being an asshole bumping this old thread, but I wanted to thank you for this tip. Installing ca_root_nss helped me with the YaRSS2-plugin in my Deluge jail. The following error was fixed after installing and I can now use RSS-feeds in my seedbox:

bozo_exception when parsing rssfeed: <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:727)>

Maybe someone else will bump in to this thread a year and a half from now having the same problem. Sorry for the necro-bump.
Sep 13, 2014
I wish I'd found this thread earlier rather than going down a rabbit hole, chasing non existant issues with torcache and client blocking.

Thanks @tprelog! Worked like a charm.