SMB - Sharing Violation - Linux Client - Excel 2010

webdawg

Contributor
Joined
May 25, 2016
Messages
112
Guys,

I have fixed this before on an openindiana box. I thought I just disabled oplocks and everything was cool.



upload_2018-8-23_11-31-36.png


I just put this in my smb aux parameters and it did not help:
Code:
kernel oplocks = no
oplocks = no
level2 oplocks = no
blocking locks = no
locking = no
strict locking = no


Any help here?
 

Attachments

  • upload_2018-8-23_11-31-48.png
    upload_2018-8-23_11-31-48.png
    9.6 KB · Views: 243
Last edited:

kdragon75

Wizard
Joined
Aug 7, 2016
Messages
2,457
Check for a hidden file by the same name. Office has its own locking system with hidden files. I have to deal with stale locks at work all the time. (20k + users)
 

webdawg

Contributor
Joined
May 25, 2016
Messages
112
No I get that.

This is during auto-save, and when I manually save the document. Even right after opening.

It has problems clearing its locks.

I can not remember what I did to fix this.
 

webdawg

Contributor
Joined
May 25, 2016
Messages
112
Allright. I am posting an update to this.

I tested all cifs versions on a archlinux client and the only way I could get this to go away was to set in the client fstab:

Code:
vers=1.0

and delete nounix


I tried 2.1, 3.0, and 3.11. From what I read locking is mandatory past 1.0? I tried on the client to set any option that would disable locking. No help.

I had this in my share config before I reverted back to really old settings:
Code:
oplocks = no
level2 oplocks = no
durable handles = no
blocking locks = no
kernel oplocks = no


did not help

I had this in the server config:

Code:
oplocks = no
locking = no
posix locking = no
strict locking = no
blocking locks = no



I tried all the diffferent cache=bla settings too.

Here is my current fstab line. This kinda sucks, I am forced to use version 1 heh.:
Code:
//server.domain/data /media/test0 cifs vers=1.0,user,cache=loose,credentials=/bla/bla/bla/bla.domain,uid=1000,gid=1000,noauto 0 0
 
Last edited:
Top