SMB Save Access Control List


Oct 16, 2023
I have looked though the forums and have not seen this issue brought up, so I am hoping that someone can help me out. I have TtrueNAS Scale setup and running well. We have created previous shares with no issues and all ACLs have been able to be applied. Recently, there was an error saveing an ACL, I think we had mask in there twice, or some other incompatible setting, but the error popped up and we went about fixing the permissions. When we saved the permissions again, the blue Save Access Control List button did nothing.

This seems to persist even after a reboot. Directly after a reboot, it will quickly show the progress bar to save the ACL, but nothing is applied and nothing seems to show up in the logs except a successful update of ACLs, even though nothing has changed and no ACLs have been applied.

I am not sure where to go from here, but I can no longer create shares, and we need to have several new shares created.

I have checked permissions on the /mnt and /mnt/<pool name> folders, and they are owned by root, so nothing has changed there. I have tried changing the owner and group permissions for the dataset that we are trying to share, but nothing changes. All other fucntinos seem to work. I can set the share permissions, I can set dataset permissions, and I can add/remove datasets without issue. I have tried to create a brand new dataset and share that, and it also does not work. ACLs on already configured SMB shares also cannot be altered. It seems that the Save Access Control List button just no longer works. i have no idea how to fix it or if anyone has seen this before.

Any help would be greatly appreciated.