SLOG not being used?

Status
Not open for further replies.

nulpwn

Cadet
Joined
Aug 10, 2018
Messages
3
While trying to understand why a vm connected to freenas using iscsi was having high write wait times i noticed that the slog volume was not being used as one can see in the following images:
Pool operations
24711-e7480bda0a7df9a0be01db769034b388.jpg


SLOG operations
24710-a4c1cd3fb1a003f614c225c77fc73fcf.jpg


After reading information on this forum on how slog works, i though it would always be used as a write cache but looks like that is not happening according to those graphs.
Have i misunderstood something on how SLOG should work? Or why the slog drive is not being used?

Thanks!
 

Attachments

  • slog_ops.png
    slog_ops.png
    89.4 KB · Views: 291
  • pool_ops.png
    pool_ops.png
    796.6 KB · Views: 273

kdragon75

Wizard
Joined
Aug 7, 2016
Messages
2,457
We neen more information. Please read the forum rules and provide the required details.
You mentioned iSCSI but you did not mention what hypervisor you are using either.
 

nulpwn

Cadet
Joined
Aug 10, 2018
Messages
3
Sorry about that.

The pool consists of 4 WD Red 4TB disks in a raid 10 configuration, a Intel Optane slog drive and a Samsung SSD L2ARC drive.
The FreeNAS box has a Intel S3420GPLX with a Intel Xeon x3470 and 32Gb of ram.
I'm running FreeNAS-11.1-U5 and ESXi 6.7.0. ESXi accesses the FreeNAS using iSCSI by the use of 2 Intel CT adapters.

Please let me know if any additional information is required.
 
Last edited:

m0nkey_

MVP
Joined
Oct 27, 2015
Messages
2,739
Talked to @nulpwn about this on IRC. iSCSI by default does not use synchronous writes, therefore the SLOG device will not be used. To overcome this, it's possible to force sync writes on a dataset with zfs set sync=always <pool>/<dataset>.
 

kdragon75

Wizard
Joined
Aug 7, 2016
Messages
2,457
Talked to @nulpwn about this on IRC. iSCSI by default does not use synchronous writes, therefore the SLOG device will not be used. To overcome this, it's possible to force sync writes on a dataset with zfs set sync=always <pool>/<dataset>.
This can be managed in the GUI now too.
 

nulpwn

Cadet
Joined
Aug 10, 2018
Messages
3
As monkey_ mentioned and explained on IRC, by default iSCSI on ESXi does not enable sync making all writes not being written to the SLOG device.
As he also mentioned even if you have a fast SLOG drive it's not straightforward that by enabling sync it will increase the performance by using, in my case it didn't but follow his advice and test it. And also don't forget the implications of running a pool with sync disabled.

Running zfs set sync=always <pool>/<dataset> or enabling it in UI as kdragon75 mentioned will make all writes go through the SLOG device.

Thank you both for your help.
 

toadman

Guru
Joined
Jun 4, 2013
Messages
619
As he also mentioned even if you have a fast SLOG drive it's not straightforward that by enabling sync it will increase the performance by using

Yes, I would think in most cases using the SLOG will decrease performance. i.e. sync=always will be lower performance than sync=standard for iscsi. Any added latency will slow things down. On sync=always you are adding latency to every write. A good SLOG will minimize the issue obviously and give you the data protection desired.
 
Status
Not open for further replies.
Top