Shadow Copies - "The previous version of (folder name) no longer exists."


Dec 27, 2020
Hi there!

I have set up my first NAS last week and so far, so good!
However I ran into a small problem with Shadow Copies in Windows.

TL; DR - when I try to open a child dataset from the snapshot (recursive) of my main dataset, I get the following error in Windows 10:


Long version - I have one big dataset (Red) with three child datasets:

The users I have in my system are:
root - I use this to setup and manage the system;
red - I use this to enter my shares from Windows. It's the owner of all my datasets and has Full Control permissions;
shield - I use this to access my Media shares from my Android TV. It's a user with limited permissions, can only read from the Media folder and nothing else.

Now, I've set up automatic recursive snapshots on the parent Red, so that I don't have to create three individual tasks for my child datasets.

The snapshots gets created all right, but from Windows I noticed the following:
1 - When I check previous versions from the parent dataset (Red), I can clearly see the snapshots:

However, if I open my Personal dataset, or any other child datasets, I get nothing:

2 - If I then go back to the parent dataset (Red) and I try to open a folder version, it opens fine:

But if I click one of the child datasets, Windows hangs for a couple of seconds, then this shows up:

Any idea what I'm doing wrong?
BTW I tried the option "Clone to New Dataset" and that worked flawlessly, so the snapshot seems to be working well!
It's just the MS Shadow Copies that are not responsive.

Thanks to everyone in advance for your help ^__^

Best Regards & Happy Holidays,