Register for the iXsystems Community to get an ad-free experience

SAS3 firmware to driver mismatch after update to FreeNAS-9.10.2-U3

Status
Not open for further replies.

mav@

iXsystems
iXsystems
Joined
Sep 29, 2011
Messages
1,342
I have already told once that there is no strong reason to update from P12 to P14, if everything works fine for you. There is a checkbox in WebUI to silence the alarm.
 

mloiterman

Dabbler
Joined
Jan 30, 2013
Messages
45
I have already told once that there is no strong reason to update from P12 to P14, if everything works fine for you. There is a checkbox in WebUI to silence the alarm.
So is the consensus here to ignore this update?
 

mav@

iXsystems
iXsystems
Joined
Sep 29, 2011
Messages
1,342
I'd install latest firmware anyway during some maintenance window, just in case. All I am telling here that there is no driver compatibility reasons to hurry with that, or blame us for pulling "new" driver in minor update.
 
Last edited by a moderator:
Joined
May 9, 2017
Messages
11
So is the consensus here to ignore this update?

Just got the same message, after FreeNAS-9.10.2-U3 (e1497f269) update, on a Supermicro server with a X10DRI-T4+ MB, and an external AOC-S3008L-L8e card. All works well so yes, I am definitely going to ignore this for a while.
 

Scampicfx

Contributor
Joined
Jul 4, 2016
Messages
122
Hey guys,

I've installed driver version 14 and firmware version 13.

I receive this warning message. When I understand it correctly, FreeNAS just doesn't "know" that firmware and driver version are correct to each other. Is there a way to "tell" FreeNAS that firmware and driver are correct? Is there any way to include this "knowledge" to the next FreeNAS bugfix release?
Maybe this could help some others who might get irritated by this warning message?

(I know I can disable this warning message. I'm thinking about other people who could get confused by this warning message?)
 

mav@

iXsystems
iXsystems
Joined
Sep 29, 2011
Messages
1,342
There is no way to tell FreeNAS that, but there is a checkbox to make it ignore that warning.
 

Morpheus187

Explorer
Joined
Mar 11, 2016
Messages
58
I got the same message but as supermicro hasn't updated their ftp with the newest version, I'm going to stick with my current version:
Code:
Adapter Selected is a Avago SAS: SAS3008(C0)
  Controller Number  : 0
  Controller  : SAS3008(C0)
  PCI Address  : 00:01:00:00
  SAS Address  : 5003048-0-1e0f-e600
  NVDATA Version (Default)  : 0b.02.30.26
  NVDATA Version (Persistent)  : 0b.02.30.26
  Firmware Product ID  : 0x2221 (IT)
  Firmware Version  : 13.00.00.00
  NVDATA Vendor  : LSI
  NVDATA Product ID  : LSI3008-IT
  BIOS Version  : 08.31.00.00
  UEFI BSD Version  : 15.00.02.00
  FCODE Version  : N/A
  Board Name  : LSI3008-IT
  Board Assembly  : N/A
  Board Tracer Number  : N/A




I've already scrubbed the whole pool with that firmware and everything is still working. Data integrity is still okay.
 

TXAG26

Patron
Joined
Sep 20, 2013
Messages
299
Supermicro just posted PH14 for the LSI 3008 HBA's.

ftp://ftp.supermicro.com/driver/SAS/LSI/3008/Firmware/
 

Scampicfx

Contributor
Joined
Jul 4, 2016
Messages
122
Hey guys,

thanks for sharing this link!

is it recommended to update to firmware 14?
I thought firmware 13 is the recommended firmware for driver 14?
 
Joined
Jul 3, 2015
Messages
621
Is there a general agreement on this now that for the 3008 chip we should be using Firmware 14 in 9.10.2-U4? As it is now using driver 15.

dev.mpr.0.driver_version: 15.01.00.00-fbsd
 
Last edited:

TXAG26

Patron
Joined
Sep 20, 2013
Messages
299
Is there a general agreement on this now that for the 3008 chip we should be using Firmware 14 in 9.10.2-U4? As it is now using driver 15.

dev.mpr.0.driver_version: 15.01.00.00-fbsd

Yes.
 
Joined
Jul 3, 2015
Messages
621
Status
Not open for further replies.
Top