Register for the iXsystems Community to get an ad-free experience

Ryzen Hyper-V

Status
Not open for further replies.

cobrakiller58

Patron
Joined
Jan 18, 2017
Messages
491
Yesterday I setup a FreeNAS nightly to tinker with on my 1800x and I noticed that importing a pool created on virtual discs doesn't work, when I tried to update the nightly from the latest ISO today the upgrade fails and a fresh install also fails. Has anyone else seen this happening?

hardware:
Ryzen 1800x
X370 gaming pro carbon
Corsair Vengeance LPX 32 GB
Samsung 960 PRO Series (containing virtual boot disc)
WD Blue M.2 (containing virtual storage pool)
10Gbe Single Port Mellanox Connectx-2
 

Chris Moore

Hall of Famer
Joined
May 2, 2015
Messages
10,070
I use Hyper-V on my Windows system to make a virtual FreeNAS for testing the new builds. I haven't tested with the latest, but it has worked in the past. The CPU is an Intel i7 but I wouldn't really expect that to make the difference.
 

cobrakiller58

Patron
Joined
Jan 18, 2017
Messages
491
I expected some eccentricities the moment I purchased a Ryzen, I'm going to have to attach some real disks to the system and see how it reacts. Do you have anything else running under Hyper-V?

Edit:alright it doesn't like updating a real disk either.
freenas_iso_update.png
 
Last edited:

cobrakiller58

Patron
Joined
Jan 18, 2017
Messages
491
A particular set of nightly's had the issue, after updating the nightly's via the GUI it has been working and auto importing the pool on a physical disk until recently when the drive failed, Virtual disks also auto imported after GUI based updates. 11.2Beta1 ISO installed into a new boot environment and imported the virtual disk pool created on the nightly train properly.
 

jclendineng

Explorer
Joined
Mar 14, 2017
Messages
58
Ryzen work pretty well with bhyve? Able to use all the cores? I am really debating building a ryzen VDI server :D
 

cobrakiller58

Patron
Joined
Jan 18, 2017
Messages
491
I have not had any stability issues so far running FreeNAS in hyper-V BUT there is another thread on the forum with people having stability issues with Ryzen and mine has not been doing any real work.I have not been allowing FreeNAS to use all my cores and I have not experimented with jails as there is an issue with IOcage jail network setup at the moment but if you're interested I can mess with that tonight.
 
Status
Not open for further replies.
Top