Reducing daily emails

Status
Not open for further replies.
Joined
Mar 9, 2015
Messages
11
Hi

Daily i get a starting scrub email and a daily run output email.

I am running freenas 11 on four Different HP microservers so although 8 emails a day might not be bad looking to reduce.

Has anyone got any advice on where these automated emails are configured?

Cheers
 

Chris Moore

Hall of Famer
Joined
May 2, 2015
Messages
10,080
Since you say that you are getting this from each of the servers, there must be some configuration you have changed that is causing a scrub to happen every day. You should not run a scrub every day and if you think that you should can you give us some background to explain?
To me, the solution is to run a scrub less often, it should be once a week at most.
 

Chris Moore

Hall of Famer
Joined
May 2, 2015
Messages
10,080

Ericloewe

Server Wrangler
Moderator
Joined
Feb 15, 2014
Messages
20,091
Joined
Mar 9, 2015
Messages
11
Thank you for your swift response.

The scrubs are not on my main volumes they are set to monthly. The scrubs relate to my Freenas-boot volumes even though the automatic scrub value is 7 days which if i understand correctly a scrub checks for errors.

So even though its set to 7 days see below does anyone know why its happening daily?

upload_2017-11-28_7-16-31.png
 
Joined
Mar 9, 2015
Messages
11
Just an update, I changed the 7 day automatic boot scrub to 14 on all free as instances and now the daily boot scrub has now stopped and happens fortnightly.

Since this is now correctly happening on all four I can only assume this is an issue with the scheduling.

That now works as expected and will wait for upgrade to reduce the emails
 

Chris Moore

Hall of Famer
Joined
May 2, 2015
Messages
10,080
if i understand correctly a scrub checks for errors.
A scrub checks the data against the checksum to ensure that the data has not been corrupted.
So even though its set to 7 days see below does anyone know why its happening daily?
Something must have been interrupting the scrub, so it didn't finish. That made the system think it still needed to do a scrub the next day. It is an unusual error. You might want to open a ticket on it so they can review the code.
What type of media are you using for the boot device?
If you are using USB memory stick, you don't want to scrub often because it will wear the drive out faster.
 
Joined
Mar 9, 2015
Messages
11
Yes using Sandisk ultra usb sticks. Would you suggest reducing the scrub to an even larger interval say monthly or even quarterly?

I suppose the answer depends on downtime caused by failed drive.

I have the config backed up so presumably a fresh install and restore of the config would not amount to massive downtime as long as the main volumes do not become corrupt due to failed boot device
 

Ericloewe

Server Wrangler
Moderator
Joined
Feb 15, 2014
Messages
20,091

Chris Moore

Hall of Famer
Joined
May 2, 2015
Messages
10,080
No. Once a week is reasonable for the boot pool.
When he had it set to 7 days it was scrubbing everyday

Sent from my SAMSUNG-SGH-I537 using Tapatalk
 

Ericloewe

Server Wrangler
Moderator
Joined
Feb 15, 2014
Messages
20,091
When he had it set to 7 days it was scrubbing everyday

Sent from my SAMSUNG-SGH-I537 using Tapatalk
Yeah, well, that's not what it's supposed to do and indicates that something is very wrong, probably with your boot pool. Start by looking at zpool status to see the scrub stats.
 
Joined
Mar 9, 2015
Messages
11
All four Freenas machines report 0 errors corrected in XXX with 0 Errors using zpool status

Will leave at 14 days and keep checking in to see what is happening

Cheers for your input
 

Chris Moore

Hall of Famer
Joined
May 2, 2015
Messages
10,080
The output of zpool status should look something like this:
Code:
  pool: freenas-boot
 state: ONLINE
  scan: scrub repaired 0 in 0h11m with 0 errors on Sat Nov 25 03:56:35 2017
config:

   NAME											STATE	 READ WRITE CKSUM
   freenas-boot									ONLINE	   0	 0	 0
	 mirror-0									  ONLINE	   0	 0	 0
	   gptid/f659fd6d-4b12-11e6-a97c-002590aecc79  ONLINE	   0	 0	 0
	   gptid/f6a61d33-4b12-11e6-a97c-002590aecc79  ONLINE	   0	 0	 0

errors: No known data errors

Would you share that with us?
 
Joined
Mar 9, 2015
Messages
11
Just noticed the last two i have cut off the final line but it just reads the same as the first two "errors: No Known data errors"
 

Chris Moore

Hall of Famer
Joined
May 2, 2015
Messages
10,080
Just noticed the last two i have cut off the final line but it just reads the same as the first two "errors: No Known data errors"
They look good to me, but you are using a single disk instead of a mirrored pair. Those Sandisk units are pretty decent.
Yes using Sandisk ultra usb sticks. Would you suggest reducing the scrub to an even larger interval say monthly or even quarterly?

I suppose the answer depends on downtime caused by failed drive.

I have the config backed up so presumably a fresh install and restore of the config would not amount to massive downtime as long as the main volumes do not become corrupt due to failed boot device
As long as you keep a current backup of the config, yes, you should be able to do a install (easiest to use the same version of FreeNAS) and load the config. That should put you right back where you were. I have had to do it a couple times myself. It is mostly just an inconvenience as long as you are prepared for it.
 
Joined
Mar 9, 2015
Messages
11
I keep The Freenas servers up to date with the latest stable train, as the config hasn't changed for a while the backup config is probably 6 months old.

I presume the upgrades would change the config as and when new features appear so i should in theory need to backup the config after every upgrade or config change.

Do you know what would happen if i restored a config that was from an earlier version of the software
 

Chris Moore

Hall of Famer
Joined
May 2, 2015
Messages
10,080
I have seen people post here about having done that and it does work. I would expect that any new features that are not set by the older configuration db would remain at the default value.
I try to go through all the menus on a new version to see what options are available / what is changed.

Sent from my SAMSUNG-SGH-I537 using Tapatalk
 
Status
Not open for further replies.
Top