Plugin Permissions and Storage Configuration

Not open for further replies.


Oct 11, 2017
I need some help setting up my HP micro server with Freenas.

I have followed these guides, but I am still having trouble setting up plugins and their permissions to be able to read and write to the NFS share.

And numerous forum posts.

Hardware/Software setup:

I have a USB stick plugged directly into the motherboard with FreeNAS version 11.1 installed. (Boot order set so USB is first)

I have 4x 4tb drives – loaded with RAIDZ (I know I only get one disk redundancy)

Plugins installed and their Jails are part of these storage but are separate to my NFS share.

  • Nas
    • NAS
      • Movies

      • TV

      • Music
    • Jails
      • Transmission_1

      • Warden-template
The part where I am struggling is setting up plugins and permissions.

I have created datasets for each folder I want on the share. (TV, Movies, Music, Downloads)

I have given all folders, datasets and storage 777 permissions with ‘nobody’ and ‘nogroup’. I have SSH’d and ran the command ‘chmod –R 777 /../..’ on each folder, dataset and storage.

I have also tried this with Root and Wheel access. I have also tried creating a user with the same UID as the plugins and making it the owner and have read/write access to storage and jails.

I have set up transmission to download to my main NFS share in the configuration, not within its own jail.

When I start the plugin up and test I either get the permissions denied error or it downloads to its own jail storage.

I wiped and started from scratch so many times….

I have used NAS4Free in the past, but thought FreeNAS was a better choice.

What am I doing wrong? Any help will be great!


Mar 18, 2014
Just confirm that you have added storage from within the jail to the dataset you are saving to ?
Then, from within the jail, check the permissions on the mount-point you used ?
Not open for further replies.