No longer getting username / password prompt for accessing my FreeNAS server using SMB share

Not open for further replies.


Nov 14, 2012

For the past two weeks I've been having a lot of difficulties with my FreeNAS server and SMB shares. I even did a complete reinstall to the newest FreeNAS version to get the problem resolved. After the reinstall it worked for a while but the same issue has returned.

I have a pretty simple setup at home for my laptop and desktop accessing my FreeNAS server using SMB shares. After a reboot I can no longer access my shares. I changed nothing with regard to the rights on the share I checked "Allow guest access" once to test my new media player and after that the problems started.

I disabled guest access again and I still had my shares mapped on my Windows 10 desktop. I was able to access the share but when I tried to remove a file it says I had no access rights.

I think for some reason I'm logged on to my FreeNAS through the guest account. So I disabled guest access on the share and now I can no longer access it. Also I no longer get a prompt to enter the username and password. The user I'm using should have all the proper file and directory access rights.

I'm at a complete loss here and already put in 6+ hours in trying to figure this out (this includes the reinstall about a week ago).

As far as I can tell both a week ago and today, the problems started after I enabled guest access and then disabled it again. I don't think my Windows 10 client is actually logging on with the proper credentials. I even tried switching the guest user to the user I use to log on and after that I can access the shares again but still not able to delete or edit anything.

I tried removing the stored credentials in my Windows 10 client and did a reboot of my FreeNAS and desktop after disabling guest access again but when I click on the FreeNAS server in the explorer I get a "No Access" error message.

Can anyone help me troubleshoot this issue?

Thank you.


Nov 26, 2017
I don't currently have access to a Win10 client to try and replicate, but from memory, a few things to check:

Are you running a DNS server on your LAN? Many home routers don't, and it often helps with SMB issues. If so, make sure both your FreeNAS and the Windows machine are using the same DNS domain, i.e. freenas.yournet.lan & win10.yournet.lan or something like that.

Also, make sure you have both machines set to the same workgroup name.

If that doesn't help, try specifying your FreeNAS box as the NETBIOS namserver in your DHCP server, if that option is available to you. Has helped me in the (distant) past.

Good luck!
Not open for further replies.