NFS shares permission denied but only until service reload


Mar 16, 2024
I can't seem to figure out NFS shares on truenas. I have couple of ver4 shares that I'm using on another machine via docker containers. Everything was working perfectly and out of the blue it stopped. On my docker machine I'm getting permission denied errors. But if I reload nfs-server service then it's ok until next server reboot.

I don't think this is my configuration problem, because this is the second time my shares broke seemingly without a reason.. My first shares used to have authorized hosts and IP addresses set.. they worked for some time and stopped with errors like "unauthorized IP" in logs (and even when I removed IPs from share settings they wouldn't work until service restart ofc, then it was ok).

So I wiped my shares clean and started fresh. This time I didn't set IP addresses thinking that was a reason for my issues. My new shares worked for 2 months and now I'm again stuck with broken NFS...

The only thing I was recently doing is frequent server restarts due to maintenance of other VMs (I'm running proxmox as a host and truenas as one of VMs).

Is it a bug or am I doing something wrong here?

TrueNAS Scale 23.10.2 (I have had this problem on past versions too).