New Docker Host/RancherVM failed to start

Nick53

Cadet
Joined
Aug 16, 2018
Messages
3
On a new FreeNAS install on I would like to test setting up a Docker virtual machine.

Expectation: A running RancherOS virtual machine.

Result: Error message "VM failed to start"
[EFAULT] VM assad failed to start: vm exit[0] reason VMX rip 0x0000000000000000 inst_length 0 status 0 exit_reason 33 qualification 0x0000000000000000 inst_type 0 inst_error 0
see extended log shown in window at https://pastebin.com/cYhtXvzh
on the console it prints
tap0: Ethernet address: 00:bd:e3:xx:xx:xx
brdige0: can't disable some capabilities on em0: 0x1
Aug 16 06:59:29 freenas dhclient[5876]: tap0: not found
Aug 16 06:59:29 freenas dhclient[5876]: exiting.


Steps to reproduce (I repeated this three times):
Install FreeNAS
Set up pool (tried names tank0 and tank)
Set up Docker Host
Keep default settings, except setting raw file location on newly created pool
Click "Start VM"

System: FreeNAS-11.2-BETA2
HP Z200 Workstation (keep in mind this is a test setup to evaluate FreeNAS, production could get new hardware)
Intel(R) Xeon(R) CPU X3450 @ 2.67GHz (8 cores)
16GB RAM
Intel VT-x enabled
FreeNAS installed on internal hd
Pool set up on two 500 GB harddrives
 

Attachments

  • firefox_2018-08-16_16-01-32.png
    firefox_2018-08-16_16-01-32.png
    60.9 KB · Views: 583
D

dlavigne

Guest
Please create a ticket at bugs.freenas.org and post the issue number here.
 

thepada

Cadet
Joined
Dec 2, 2018
Messages
1
Hey,

I have the same error but i'm not able to check the link, for a solution.
Has there came one up?

thank you :)
 

Nick53

Cadet
Joined
Aug 16, 2018
Messages
3
Which FreeNAS version did you try? What system (processor, RAM, motherboard) are you running it on?
Could you provide a debug file? System->Advanced->SAVE DEBUG

For me there was no solution yet.
 
Top