Need Serious Help PLS

Status
Not open for further replies.

zaerst

Cadet
Joined
Jun 6, 2011
Messages
8
So I stupidly tried to upgrade to new beta and have totally hosed my sys it seems... If anyone is able to help pls let me know what to do!

Basically after upgrade when my sys tries to boot up it fails and gives me all kinds of errors.

/dev/ufs/FreeNASs4: No write access
/dev/ufs/FreeNASs4: unexpected inconsistency; run fsck manually.
/dev/ufs/FreeNASs3: file system clean; skipping checks
/dev/ufs/FreeNASs3: clean

The following file system had an unexpected inconsistency:
ufs: /dev/ufs/FreeNASs4 (/data)
Automatic filesystem check failed' help!
Error: aborting boot (sending sigterm to parent)
june 7 init: /bin/sh on /etc/rc terminated abnormally, going to single user mode
june 7 init: NSSswitch (_nsdispatch): files, passws_compat, endpwent, not found, and no fallback proivded.

Then goes to shell. Hopefully I did just not lose all my data, anyway at all to get it back? My main FS was Zraid1 on 5 2tb disks. :(
 

Tekkie

Patron
Joined
May 31, 2011
Messages
352

jgreco

Resident Grinch
Joined
May 29, 2011
Messages
18,681
It isn't time to panic just yet. The FreeNAS system uses a good strategy for its OS upgrades. It seems, however, that something went sour with the FreeNASs4 partition, which is shared between the two OS's, and is where /data is stored.

When I deliberately mash a FreeNAS system, upon reboot, I get the expected

Trying to mount root from ufs:/dev/ufs/FreeNASs1a
WARNING: /data was not properly dismounted

because /data's clean flag isn't set. The system then does a preen fsck, which is again what I'd expect.

It looks like yours is experiencing some problem during the preen fsck. So the most helpful thing you could probably do at this point would be to go to the shell prompt and type

% fsck -n /dev/ufs/FreeNASs4

which might give some further insight into the nature of the problem without actually risking writing anything to the potentially damaged filesystem. From there we can proceed to determine the next best steps.
 

zaerst

Cadet
Joined
Jun 6, 2011
Messages
8
I do get some errors before this but I cant see them because they go to fast. Anyways fsck looks to be fine on there:

/dev/ufs/FreeNASs4 (NO WRITE)
Last mounted on /data
Phase 1
Phase 2
Phase 3
Phase 4
Phase 5
10 files, 1013 used, 39514 free (18 frags, 4937 blocks, 0.0% fragmentation)
 

William Grzybowski

Wizard
iXsystems
Joined
May 27, 2011
Messages
1,740
I do get some errors before this but I cant see them because they go to fast. Anyways fsck looks to be fine on there:

/dev/ufs/FreeNASs4 (NO WRITE)
Last mounted on /data
Phase 1
Phase 2
Phase 3
Phase 4
Phase 5
10 files, 1013 used, 39514 free (18 frags, 4937 blocks, 0.0% fragmentation)

That is a bug in the migration and has been fixed on trunk... I suggest you to boot in the recovery partition, copying the database backup and wait for -BETA2...
 

zaerst

Cadet
Joined
Jun 6, 2011
Messages
8
Booting into F2 I get similar errors... If I just scrap the system and start over on 8 REL will I be able to import the pool?
 

zaerst

Cadet
Joined
Jun 6, 2011
Messages
8
Zpool status shows the pool as fine... *cries* All my data right there but yet so far away! :(
 

zaerst

Cadet
Joined
Jun 6, 2011
Messages
8
When I try zpool export it says no pool by name of russia (my pool)
Import tools shows the dataset but does not work.
 

zaerst

Cadet
Joined
Jun 6, 2011
Messages
8
pool: russia
id: #############
state: online
status: the pool was last accessed by another system.

zpool export russia
cannot open 'russia' : no such pool
 

zaerst

Cadet
Joined
Jun 6, 2011
Messages
8
DISASTER averted! Clean install of beta instead of rel and i was able to import my zfs pool.
Lesson learned...
 
Status
Not open for further replies.
Top