LAGG issue

Bane

Dabbler
Joined
Dec 31, 2017
Messages
43
I have the latest TrueNAS Core with a mellanox 25g card with 2 ports. I have setup a lagg interface with LACP. The lagg0 interface shows no carrier, even though both NIC's show carrier. The switch is configured for lacp, and is working correctly with a linux based server already. What can I look at to trouble shoot this issue?
 
Last edited:
Joined
Dec 29, 2014
Messages
1,133
What kind of switch (as in what manufacturer)? Did you configure the LAGG on the TrueNAS side to use LACP? Can you provide a screenshot of the switch side config?
 

Bane

Dabbler
Joined
Dec 31, 2017
Messages
43
What kind of switch (as in what manufacturer)? Did you configure the LAGG on the TrueNAS side to use LACP? Can you provide a screenshot of the switch side config?

The switch is a ubiquiti USW-aggregation pro. I configured lagg with LACP through the local TrueNAS menu interface.

Here are a few screen shots:

1707361065861.png

1707361099296.png


Switch port config:

1707361245565.png
 
Last edited:
Joined
Dec 29, 2014
Messages
1,133
No carrier makes me think there is more to this than that. Even if the LAGG doesn't come up, you should have carrier. I personally loathe forcing speed and duplex. My personal experience is that forcing speed and duplex has caused way more problems than it ever solved, but your mileage may vary. Here is what the TrueNAS side looks like for one of my bare metal TrueNAS systems.
1707397672023.png

And here is what the Cisco switch side look like.
Code:
interface Port-channel45
 description FreeNAS2
 switchport trunk native vlan 3
 switchport trunk allowed vlan 1,3
 switchport mode trunk
 switchport nonegotiate
 spanning-tree portfast
!
interface TenGigabitEthernet1/0/45
 description FreeNAS2
 switchport trunk native vlan 3
 switchport trunk allowed vlan 1,3
 switchport mode trunk
 switchport nonegotiate
 power inline never
 channel-group 45 mode active
 spanning-tree portfast
!
interface TenGigabitEthernet2/0/45
 description FreeNAS2
 switchport trunk native vlan 3
 switchport trunk allowed vlan 1,3
 switchport mode trunk
 switchport nonegotiate
 power inline never
 channel-group 45 mode active
 spanning-tree portfast

I have done this with Cisco, HP, and H3C switches, but I don't have any experience with Ubiquiti.
 

Bane

Dabbler
Joined
Dec 31, 2017
Messages
43
No carrier makes me think there is more to this than that. Even if the LAGG doesn't come up, you should have carrier. I personally loathe forcing speed and duplex. My personal experience is that forcing speed and duplex has caused way more problems than it ever solved, but your mileage may vary. Here is what the TrueNAS side looks like for one of my bare metal TrueNAS systems.
View attachment 75485
And here is what the Cisco switch side look like.
Code:
interface Port-channel45
 description FreeNAS2
 switchport trunk native vlan 3
 switchport trunk allowed vlan 1,3
 switchport mode trunk
 switchport nonegotiate
 spanning-tree portfast
!
interface TenGigabitEthernet1/0/45
 description FreeNAS2
 switchport trunk native vlan 3
 switchport trunk allowed vlan 1,3
 switchport mode trunk
 switchport nonegotiate
 power inline never
 channel-group 45 mode active
 spanning-tree portfast
!
interface TenGigabitEthernet2/0/45
 description FreeNAS2
 switchport trunk native vlan 3
 switchport trunk allowed vlan 1,3
 switchport mode trunk
 switchport nonegotiate
 power inline never
 channel-group 45 mode active
 spanning-tree portfast

I have done this with Cisco, HP, and H3C switches, but I don't have any experience with Ubiquiti
Unfortunately I can't get to the web interface be because the lagg is not working. The switch is indicating it is on the TrueNAS side. Do you know if there are any logs or anything I can look at in TrueNAS shell to troubleshoot this?
 
Joined
Dec 29, 2014
Messages
1,133
Does the ubiuti have a setting for active versus passive LACP? I don't know if TrueNAS uses active or passive. I know my Cisco switch is set to active. Two passive LACP devices will never bring up the LAGG because neither one will initiate LACP, they only respond to requests initiated by the other side. I do see the LAGG protocol as LACP on the TrueNAS side. I wonder if the ubiquiti side isn't doing LACP or is passive, but I don't have any experience with ubiquiti.
 

Bane

Dabbler
Joined
Dec 31, 2017
Messages
43
Does the ubiuti have a setting for active versus passive LACP? I don't know if TrueNAS uses active or passive. I know my Cisco switch is set to active. Two passive LACP devices will never bring up the LAGG because neither one will initiate LACP, they only respond to requests initiated by the other side. I do see the LAGG protocol as LACP on the TrueNAS side. I wonder if the ubiquiti side isn't doing LACP or is passive, but I don't have any experience with ubiquiti.
I've opened a support case with ubiquiti. I can't find anything that says whether it's active or passive lacp.
 

Patrick M. Hausen

Hall of Famer
Joined
Nov 25, 2013
Messages
7,444
You configured your lagg0 with em0 and em1 as members instead of mce0 and mce1, probably.
 
Joined
Dec 29, 2014
Messages
1,133

Bane

Dabbler
Joined
Dec 31, 2017
Messages
43
You configured your lagg0 with em0 and em1 as members instead of mce0 and mce1, probably.

Very odd stuff happening. When trying to configure lagg I get the below.

1707432371022.png


However if I then go to try to delete lagg, it says no lagg configured.

1707432268729.png


The network interfaces do show up as shown here.
1707432440079.png

And according to the shell no lagg is configured.

1707432514541.png


Should I maybe try reseting the configuration to defaults?
 

Bane

Dabbler
Joined
Dec 31, 2017
Messages
43
I decided to go ahead and reset the configuration, and the issues seem to be gone. I reconfigured lagg and now it links up and all is well.
 
Top