Jumbo Frames lagg0

Status
Not open for further replies.

VioletDragon

Patron
Joined
Aug 6, 2017
Messages
251
Howdy folks,

I have some serious issues with Jumbo Frames in FreeNAS. I have enabled VLANS, Trunking and Jumbo frames on my HP Procurve switch. However when enabling mtu 9000 it causes the whole freenas server to dropout and slow issues when transferring too or from the Server.

I know its not a issue with my config on the switch because Linux to Linux works perfectly fine so does Windows to Linux or Linux to Windows with Full speeds. I am limited to 500mbs throughput in Linux however i get full speeds upto 1gbp throughput in Windows with 1500 MTU. I know the linux client isnt a issue here because i get 1gbp throughput from and too a linux box or from and too a Windows machine. Any ideas? because i am out of ideas.

Thanks.

Jack.
 
D

dlavigne

Guest
Depends upon the capabilities of the FreeBSD driver. What's the output of ifconfig?
 

VioletDragon

Patron
Joined
Aug 6, 2017
Messages
251
Depends upon the capabilities of the FreeBSD driver. What's the output of ifconfig?

Hey thanks for getting back to. The ouput is.

Code:
em0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
	options=98<VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM>
	ether 00:24:81:7d:94:90
	hwaddr 00:24:81:7d:94:91
	nd6 options=9<PERFORMNUD,IFDISABLED>
	media: Ethernet autoselect (1000baseT <full-duplex>)
	status: active
em1: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
	options=98<VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM>
	ether 00:24:81:7d:94:90
	hwaddr 00:24:81:7d:94:90
	nd6 options=9<PERFORMNUD,IFDISABLED>
	media: Ethernet autoselect (1000baseT <full-duplex>)
	status: active
em2: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
	options=98<VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM>
	ether 00:24:81:7d:94:90
	hwaddr 00:24:81:7d:94:93
	nd6 options=9<PERFORMNUD,IFDISABLED>
	media: Ethernet autoselect (1000baseT <full-duplex>)
	status: active
em3: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
	options=98<VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM>
	ether 00:24:81:7d:94:90
	hwaddr 00:24:81:7d:94:92
	nd6 options=9<PERFORMNUD,IFDISABLED>
	media: Ethernet autoselect (1000baseT <full-duplex>)
	status: active
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
	options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
	inet6 ::1 prefixlen 128
	inet6 fe80::1%lo0 prefixlen 64 scopeid 0x5
	inet 127.0.0.1 netmask 0xff000000
	nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
	groups: lo
lagg0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
	options=98<VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM>
	ether 00:24:81:7d:94:90
	inet 192.168.1.1 netmask 0xffffff00 broadcast 192.168.1.255
	inet 192.168.1.122 netmask 0xffffff00 broadcast 192.168.1.255
	nd6 options=9<PERFORMNUD,IFDISABLED>
	media: Ethernet autoselect
	status: active
	groups: lagg
	laggproto loadbalance lagghash l2,l3,l4
	laggport: em0 flags=4<ACTIVE>
	laggport: em1 flags=4<ACTIVE>
	laggport: em2 flags=4<ACTIVE>
	laggport: em3 flags=4<ACTIVE>
bridge0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
	ether 02:51:06:95:d0:00
	nd6 options=1<PERFORMNUD>
	groups: bridge
	id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15
	maxage 20 holdcnt 6 proto rstp maxaddr 2000 timeout 1200
	root id 00:00:00:00:00:00 priority 32768 ifcost 0 port 0
	member: epair0a flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
			ifmaxaddr 0 port 8 priority 128 path cost 2000
	member: lagg0 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
			ifmaxaddr 0 port 6 priority 128 path cost 5000
epair0a: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
	options=8<VLAN_MTU>
	ether 02:f4:50:00:08:0a
	hwaddr 02:f4:50:00:08:0a
	nd6 options=1<PERFORMNUD>
	media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)
	status: active
	groups: epair
 
D

dlavigne

Guest
Ok, the driver is capable, from em(4):

Support for Jumbo Frames is provided via the interface MTU setting.
Selecting an MTU larger than 1500 bytes with the ifconfig(8) utility
configures the adapter to receive and transmit Jumbo Frames. The maximum
MTU size for Jumbo Frames is 16114.

Anything in /var/log/messages related to the network?
 

VioletDragon

Patron
Joined
Aug 6, 2017
Messages
251
Ok, the driver is capable, from em(4):

Support for Jumbo Frames is provided via the interface MTU setting.
Selecting an MTU larger than 1500 bytes with the ifconfig(8) utility
configures the adapter to receive and transmit Jumbo Frames. The maximum
MTU size for Jumbo Frames is 16114.

Anything in /var/log/messages related to the network?

I should be able to get 9000 Jumbo with this card i do in linux anyway.
 

VioletDragon

Patron
Joined
Aug 6, 2017
Messages
251
Ok, the driver is capable, from em(4):

Support for Jumbo Frames is provided via the interface MTU setting.
Selecting an MTU larger than 1500 bytes with the ifconfig(8) utility
configures the adapter to receive and transmit Jumbo Frames. The maximum
MTU size for Jumbo Frames is 16114.

Anything in /var/log/messages related to the network?

Sorry i forgot to attach the logs. Had to attach in a logs txt file as it exceeds 3000.
 

Attachments

  • logs.txt
    30.8 KB · Views: 441
Status
Not open for further replies.
Top