iocage Plex no metadata

Not open for further replies.


Sep 11, 2017
Found a few threads that have me thinking but nothing seems to match my scenario...

I already had Plex in a warden jail, has been working great. Wanted to update a while ago and found out through here I believe, that I had to do it in the new iocage jails. First try a while ago failed, I didn't know what I did wrong so it went on the backburner. Tried again a few days ago and with a few different threads on iocage stuff was able to get plex working just fine. I didn't add any libraries right away, no time, but plex was running and I could see it everywhere.

I go to add a few libraries today and remembered I have to add storage, got that figured out I least plex was able to locate the media and add it to the movie library. However, I was not getting any metadata, at first I tried different agents, nothing worked.

As part of my iocage process I am combining datasets...well made a new one and throwing all my media into need to have 7 network locations for different types of I added the same new dataset to old warden plex. Added a library and metadata loaded just fine so that got me thinking permissions?

I just added a DVR and tried to record and get a no write access error.

When the second plex server was created it created a plex user and group, I assume if it already existed it would ignore it. I think there is still just one, I don't think the jail type would change a user around at all. The new dataset has plex user and group as the the owner.

I have checked all the folders permissions and they are all set to plex. Is it the "wrong" plex user? I will be deleting the warden jail as soon as I have the iocage jail up and running. I cp the data over through ssh with a few options to basically preserve everything. Could the media be under the warden Plex user and the new iocage plex user doesn't think it is the same? Does that make sense?

Is this actually a permission issue?

Edit: The media does not play from the iocage jail, but does play from the warden jail. Warden jail plays both old and new dataset media and metadata loads for both as well. Only problem is with iocage jail.
Last edited:
Not open for further replies.