Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

install DELUGE in a jail

SlackerDude

Member
Joined
Feb 1, 2014
Messages
41
Hi guys. I am very interested in getting this running on my own FreeNAS-9.3-STABLE-201512121950. I've been hitting the snag of step #6, and have not been able to get past it yet. Has anyone successfully got this installed, and if so, be willing to share? Apparently I need step-by-step on this one, my newbness is shining bright. :-(
 

icsy7867

Member
Joined
Dec 31, 2015
Messages
159
Here's what I did and I have two different deluge jails running, and they all appear to be running correctly!

I could not get Steps 5 and 6 to work correctly. I believe rasterbar/deluge has updated to the point of not needing this.

I simply ran:
pkg install nano
pkg install bash
pkg install deluge

And go deluge straight from the default repo. After this I picked back up on Step 7, which seemed to work just fine for me.
 

SlackerDude

Member
Joined
Feb 1, 2014
Messages
41
Thanks for the reply, Icsy7867. So, in a standard jail, follow your steps & then pick back up at step 7 from above? I'll give it another shot & report my success/failure.
 

cbrherms

Neophyte
Joined
Jan 23, 2016
Messages
10
Hey all,
Successfully installed on FreeNAS9.3.1 so thanks for all the pointers!
Couple of issues i had though, standard plugins wouldn't stick when activated via the WebUI, had to create /.python-eggs and chmod 777 it to allow the extraction of the plugins before moving to the plugins folder.
Also though, struggling with getting the WebUI to auto connect to daemon. Not too much of an issue, just means i have to set up my torrent handler to use the daemon instead of the webui, but here's the thing:
-terminated deluged to edit web.conf so that default daemon was 127.0.0.1:58846
-that didn't stick on reboot, got overwritten, realised i had to terminate both deluged and delugew then make my changes.
Settings stuck on next reboot but still getting daemon popup with "online" status and not "connected" when i first load up the WebUI, any ideas why?
 

NavyGimp

Newbie
Joined
Nov 18, 2014
Messages
1
I'm not sure if it was the most efficient or correct way to do it but, I went to the /usr/ports/net-p2p/libtorrent-rasterbar directory and ran 'make install clean'. This took awhile but after it was done I now had the rest of the 'work/...' directory. Just be aware of the version difference for libtorrent-rasterbar-1.0.6.

Other differences from the current guide includes:

  • There are TWO ' #define TORRENT_ICONV_ARG (char**)' lines that need to be changed.
  • Under step 13.2.1 - the line should read 'echo "[username]:[password]:10" >> /home/deluge/.config/deluge/auth
I've got Deluge running in the same jail as Sonarr, Couchpotato, Sabnzbd, Headphones, and Handbrake all with OpenVPN security using PIA. I'm pretty impressed with it. :) I call it my personal DVR. I'll make a guide on how I made it once I'm done remodeling my house. Priorities come first. Hope this helps.
I don't suppose you've finished your house? I'd love to duplicate your setup!
 

SkyMonkey

Member
Joined
Mar 13, 2013
Messages
102
Thanks, this guide worked great. Started with the pkg installs which icsy7867 recommended, then proceeded from step 7. Only modification I had to make was the 2nd one stated by SpaceAvenger69:
  • Under step 13.2.1 - the line should read 'echo "[username]:[password]:10" >>/home/deluge/.config/deluge/auth
Other than that, worked great. Had to fix jail -> mount point permissions (as usual), but up and running now!

Thanks so much!
 

Karrok

Neophyte
Joined
Feb 13, 2014
Messages
5
Hi, I followed the guide, and have the WEB UI running. However, since deluge:deluge user/group got created while strictly following the guide, it means none of my other plugins can move/delete downloaded items after deluge copies completed downloads to mounted storage ie. /mnt/vol1/unsorted. Couchpotato and sickbeard both monitor unsorted, and if they find anything they move it to /mnt/vol1/series or /mnt/vol1/movies.

Is there a way to give other plugin jails (my other jails are all nobody:nogroup) enough access to move/delete files created by deluge?
 

Nucshuco

Member
Joined
Aug 22, 2014
Messages
52
Hi, I followed the guide, and have the WEB UI running. However, since deluge:deluge user/group got created while strictly following the guide, it means none of my other plugins can move/delete downloaded items after deluge copies completed downloads to mounted storage ie. /mnt/vol1/unsorted. Couchpotato and sickbeard both monitor unsorted, and if they find anything they move it to /mnt/vol1/series or /mnt/vol1/movies.

Is there a way to give other plugin jails (my other jails are all nobody:nogroup) enough access to move/delete files created by deluge?
Edit the startup script and change the user from deluge to delugew_user="nobody"
 

Karrok

Neophyte
Joined
Feb 13, 2014
Messages
5
Thank you very much, that did the trick! :)


Oh, actually it didn't quite :(

Deluge still creates files/folders as drwxr-xr-x even tho the temp dir it downloads to is drwxrwxrwx.

How can I ensure deluge makes new things as 777 / drwxrwxrwx ?

I tried chmod -R 777 incomplete/ but that apparently doesn't change the rights deluge uses to create new files/folders.
 
Last edited:

Nucshuco

Member
Joined
Aug 22, 2014
Messages
52
Thank you very much, that did the trick! :)


Oh, actually it didn't quite :(

Deluge still creates files/folders as drwxr-xr-x even tho the temp dir it downloads to is drwxrwxrwx.

How can I ensure deluge makes new things as 777 / drwxrwxrwx ?

I tried chmod -R 777 incomplete/ but that apparently doesn't change the rights deluge uses to create new files/folders.
I gave up trying to get deluge to do 777. I changed the startup scripts in couchpotato and sickrage to
sickrage_user:="nobody"
sickrage_group:="nobody"
couchpotato_user:="nobody"
couchpotato_group:="nobody"
 

Karrok

Neophyte
Joined
Feb 13, 2014
Messages
5
How and where would I change that?

f/e my /etc/rc.d in couchpotato jail doesn't even have a config file called "couchpotato"
 
Last edited:

Nucshuco

Member
Joined
Aug 22, 2014
Messages
52
Look in /usr/local/etc/rc.d
 
Last edited:

dasti

Member
Joined
Jun 11, 2014
Messages
69
updated the guide for freenas 9.10

the ports has no more problems with rasterbar and I figured out how to use the startup scripts correctly

enjoy !
 

Wolfeman0101

Senior Member
Joined
Jun 14, 2012
Messages
404
updated the guide for freenas 9.10

the ports has no more problems with rasterbar and I figured out how to use the startup scripts correctly

enjoy !
I'm trying to install on FreeNAS 9.10 and I'm running into an issue at step 11.1.2. I can't get the web daemon to start.

Code:
root@Deluge:/ # service deluge-web start
/etc/rc.conf: deluge-web_enable=YES: not found
deluge-web does not exist in /etc/rc.d or the local startup
directories (/usr/local/etc/rc.d)
root@Deluge:/ #


It's weird because rc.conf has enable=YES
Code:
root@Deluge:/ # cat /etc/rc.conf
portmap_enable="NO"
sshd_enable="NO"
sendmail_enable="NO"
sendmail_submit_enable="NO"
sendmail_outbound_enable="NO"
sendmail_msp_queue_enable="NO"
hostname="Deluge"
devfs_enable="YES"
devfs_system_ruleset="devfsrules_common"
inet6_enable="YES"
ip6addrctl_enable="YES"
deluged_enable="YES"
deluged_user="deluge"
deluge-web_enable="YES"
root@Deluge:/ #
 

Wolfeman0101

Senior Member
Joined
Jun 14, 2012
Messages
404
I figured out it was a typo in step 11.1.2. It should be deluge_web not deluge-web.

Code:
root@Deluge:/usr/local/etc/rc.d # ll
total 35
-r-xr-xr-x  1 root  wheel  1804 May 16 19:01 deluge_web*
-r-xr-xr-x  1 root  wheel  1843 May 16 19:01 deluged*
-r-xr-xr-x  1 root  wheel   678 Mar 28 18:20 git_daemon*
-rwxr-xr-x  1 root  wheel   832 May 16 18:22 pbid*
-r-xr-xr-x  1 root  wheel  1021 Mar 21 18:19 svnserve*
 

cbrherms

Neophyte
Joined
Jan 23, 2016
Messages
10
Ran in to exactly the same problem as above to the letter.

EDIT: appears it's a typo in the guide. Should be

Code:
echo 'deluge_web_enable="YES"' >> /etc/rc.conf
echo 'deluge_web_user="deluge"' >> /etc/rc.conf


EDIT2: looks like i was beaten to it by above poster
 
Last edited:

Wolfeman0101

Senior Member
Joined
Jun 14, 2012
Messages
404
Ran in to exactly the same problem as above to the letter.
Now when I try to start deluge_web I get this error.

Code:
root@Deluge:/ # service deluge_web start
/usr/local/etc/rc.d/deluge_web: WARNING: /home/asjklasdfjklasdf/.config/deluge is not a directory.
/usr/local/etc/rc.d/deluge_web: WARNING: failed precmd routine for deluge_web
 
Top