Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

install DELUGE in a jail

Joined
Mar 16, 2016
Messages
132
hello all

i'm new to freenas and i just installed the deluge. I use deluge and sonarr in a windows environment and would like to replicate the same on my freenas box. I'm running frenass 11.2 rc1 and deluge is ver 1.3.15

in trying to install the deluge webgui plugin it is asking me for and "egg" I have no clue what this is and no idea on what to insert as local host in sonarr. can some one help with this installation
thank you
 
Joined
Sep 13, 2014
Messages
141
Deluge's Plugins are packaged in egg files. Think of them as a .zip or .jar file. It's simply a container. The egg files can be found here - https://dev.deluge-torrent.org/wiki/Plugins.

As for actually getting them into the Jail, there are several methods, wget for example, but if I remember correctly (it's been a while since I installed a plugin in Deluge), you could connect to the Deluge daemon on the server using the GTK client (Deluge installed on your local machine and the interface set to non-Classic mode) and then install the plugin. I'm pretty sure the plugin is installed to the server at the same time.
 

Wolfeman0101

Senior Member
Joined
Jun 14, 2012
Messages
404
When I ran a pkg upgrade a few days ago it removed deluge and now I can't reinstall it.

Code:
root@deluge:/usr/ports/net-p2p/deluge # pkg install deluge
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
Updating database digests format: 100%
pkg: No packages available to install matching 'deluge' have been found in the repositories
 

Morcam

Newbie
Joined
Feb 12, 2015
Messages
2
When I ran a pkg upgrade a few days ago it removed deluge and now I can't reinstall it.

Code:
root@deluge:/usr/ports/net-p2p/deluge # pkg install deluge
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
Updating database digests format: 100%
pkg: No packages available to install matching 'deluge' have been found in the repositories
This is apparently due to an issue one of the dependencies being marked as broken. I tried compiling via ports and get errors there too. It seems easier to me to just do what the person here suggested:
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=243150

Which is:
Edit /etc/pkg/FreeBSD.conf

Change

url: "pkg+http://pkg.FreeBSD.org/${ABI}/quarterly",

to

url: "pkg+http://pkg.FreeBSD.org/${ABI}/release_1",

then you can pkg install deluge
And I'll just have to come back to this in a month or two once it's fixed and swap it back.
 

Wolfeman0101

Senior Member
Joined
Jun 14, 2012
Messages
404
This is apparently due to an issue one of the dependencies being marked as broken. I tried compiling via ports and get errors there too. It seems easier to me to just do what the person here suggested:
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=243150

Which is:


And I'll just have to come back to this in a month or two once it's fixed and swap it back.
Thanks but it still isn't working.

Code:
root@deluge:~ # pkg install deluge
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
pkg: No packages available to install matching 'deluge' have been found in the repositories
root@deluge:~ # cat /etc/pkg/FreeBSD.conf
# $FreeBSD: releng/11.3/etc/pkg/FreeBSD.conf 347034 2019-05-02 23:59:44Z gjb $
#
# To disable this repository, instead of modifying or removing this file,
# create a /usr/local/etc/pkg/repos/FreeBSD.conf file:
#
#   mkdir -p /usr/local/etc/pkg/repos
#   echo "FreeBSD: { enabled: no }" > /usr/local/etc/pkg/repos/FreeBSD.conf
#

FreeBSD: {
  url: "pkg+http://pkg.FreeBSD.org/${ABI}/release_1",
  mirror_type: "srv",
  signature_type: "fingerprints",
  fingerprints: "/usr/share/keys/pkg",
  enabled: yes
}
root@deluge:~ #
 

Morcam

Newbie
Joined
Feb 12, 2015
Messages
2
Thanks but it still isn't working.

Code:
root@deluge:~ # pkg install deluge
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
pkg: No packages available to install matching 'deluge' have been found in the repositories
root@deluge:~ # cat /etc/pkg/FreeBSD.conf
# $FreeBSD: releng/11.3/etc/pkg/FreeBSD.conf 347034 2019-05-02 23:59:44Z gjb $
#
# To disable this repository, instead of modifying or removing this file,
# create a /usr/local/etc/pkg/repos/FreeBSD.conf file:
#
#   mkdir -p /usr/local/etc/pkg/repos
#   echo "FreeBSD: { enabled: no }" > /usr/local/etc/pkg/repos/FreeBSD.conf
#

FreeBSD: {
  url: "pkg+http://pkg.FreeBSD.org/${ABI}/release_1",
  mirror_type: "srv",
  signature_type: "fingerprints",
  fingerprints: "/usr/share/keys/pkg",
  enabled: yes
}
root@deluge:~ #
Oh. In retrospect, I was installing deluge-cli, which is what the linked answer was for. Which is the same thing, but headless, so you can use either the web interface or the remote GTK interface. Which seems to make sense for a jail. Will that work for you?

pkg install deluge-cli
 
Top