Help with TRUNK setup

lthasenhod

Cadet
Joined
Mar 7, 2020
Messages
7
Hi All,

I cant seem to get trunk setup to work, my setup is as follows:

Cisco Nexus Switch:

interface port-channel20
description *** TrueNAS Scale TEST ***
switchport mode trunk

interface Ethernet1/19
switchport mode trunk
channel-group 20 mode active

interface Ethernet1/20
switchport mode trunk
channel-group 20 mode active

TrueNAS Scale:

I cant seem to figure out how to bond the 2 interfaces (eno1/eno2), without TrueNAS complaining about overlapping ip adresses, what i would like in the end is that to have a trunk with vlans between the TrueNAS Scale and the Cisco Switch, that i then can use for VM's.

please advice.

Kind Regards,

lthasenhod
 

Patrick M. Hausen

Hall of Famer
Joined
Nov 25, 2013
Messages
7,776
Don't assign ip addresse for eno1 and eno2. Create a bond0 LAGG interface with LACP. Reboot. Then create VLAN interfaces with bond0 as the parent interface. Assign the IP addresses to the VLAN interfaces as necessary.
 

jgreco

Resident Grinch
Joined
May 29, 2011
Messages
18,680
So, you may have misunderstood the terminology.

You are trying to set up a link aggregation.

On your switch, do:

interface Ethernet1/19
no switchport mode trunk
exit
interface Ethernet1/20
no switchport mode trunk
exit

because declaring other stuff when you've added a physical port to a LACP portgroup is just confusing as all hell.

Now, on your FreeNAS, delete whatever networking you've done. Then, start at the ground level by setting up the link aggregation. Just like on the switch, this is the foundation for building your actual network link.

You will then create a vlan interface for each vlan using the lagg as the parent device.

Then you configure your IP on top of the vlan interface (one for each virtual network).

Done.

You cannot configure multiple interfaces onto the same network segment, which is where you would end up with the OS complaining about what you are doing. However, when you do this correctly, you only have a single interface ... it's virtual. The physical interfaces end up being consumed by the network stack to build the link aggregation, and other than that, you DO NOT TOUCH IT. It does not get an IP address, it does not get configured for DHCP. Configuring stuff on the LACP interface or component interfaces is the FreeNAS equivalent of the switch misconfiguration I showed you how to clear up above.
 
Top