Having a problem connecting

Not open for further replies.


Jun 15, 2011
Hi all - I was trying to change my FreeNAS boxes settings so i could access it at work. It looks like I have thrown the settings off and can't even connect via the local ip anymore. Do you know how I would go about restoring the original settings?

Also, how do i setup the networking via the GUI to accept connections from outside of my local network? It was a little confusing for me.

Thank you ahead of time!

Edit: When looking at the command line interface i'm shown this:

"You may try the following URLs to access the web user interface:"
Obviously i messed something up!


Jun 18, 2011

I think I had the EXACT same issue you had. I also want a way to get back the "original settings". I need it to work from the console cause I cannot access the box from local IP. (I found your post while looking for an answer)

I found two ways to fix this:

1) The first was to simply reinstall to the USB device after booting the FreeNAS v8 CD.

Problem with this method is that I am building this system new and in the end there will not be a CD drive. So... even though that worked it is not satisfactory fix for me. I need to be able to restore factory settings from the console.

Once I had it working again I broke it again by changing the IP in the GUI (hummmm) then when I could no longer access I went to console and tried to adjust the interface. I came up with this lagg0 interface and everything seemed broken again.

2) the following steps seem to get me working again from the console:

cd /data
mount -u -wv /data
mv freenas-v1.db freenas-v1.db.old
cp factory-v1.db freenas-v1.db 
chown www:www freenas-v1.db 
ls -laF

(8) reboot the system

After the reboot I went to (1) interface config in the console menu to make sure I did not see any longer.

Seems to work now like new again. I hope someone will comment with better method or correct any mistakes. I am new to FreeNAS v8

Not open for further replies.