• Currently using VMware at work? We want to hear from you.

    Thinking of making a switch from VMware? We'd love to hear your thoughts and feedback about which hypervisor you have been researching or already using. Click here to vote and share your thoughts! You can vote HERE!

Got a warning my zfs pool is degraded

Status
Not open for further replies.

Estropelic

Contributor
Joined
Feb 8, 2016
Messages
103
Where do I begin? Is one of my drives down? Should I shut the machine down in the meantime to look at this in the morning? I have a backup drive available in the closet but it's too early to look into the issue now.


Checking status of zfs pools:
NAME SIZE ALLOC FREE EXPANDSZ FRAG CAP DEDUP HEALTH ALTROOT
FREENASPOOL 10.9T 1.76T 9.11T - 11% 16% 1.00x ONLINE /mnt
freenas-boot 7.44G 3.70G 3.74G - - 49% 1.00x DEGRADED -

pool: freenas-boot
state: DEGRADED
status: One or more devices could not be opened. Sufficient replicas exist for
the pool to continue functioning in a degraded state.
action: Attach the missing device and online it using 'zpool online'.
see: http://illumos.org/msg/ZFS-8000-2Q
scan: scrub repaired 0 in 0h5m with 0 errors on Tue Nov 21 03:50:57 2017
config:

NAME STATE READ WRITE CKSUM
freenas-boot DEGRADED 0 0 0
mirror-0 DEGRADED 0 0 0
gptid/91c2c7cf-de87-11e5-95f4-d05099c08766 ONLINE 0 0 0
7072526115577093593 UNAVAIL 0 0 0 was /dev/gptid/0e6d0473-e070-11e5-b5b4-d05099c08766

errors: No known data errors

Local system status:
3:01AM up 2 days, 7:25, 0 users, load averages: 1.56, 1.15, 1.19

-- End of daily output --
 

Estropelic

Contributor
Joined
Feb 8, 2016
Messages
103
So it looks like one of my USB ports on my case took a dive. I moved the USB device to the other port and it lit right up. I attached a USB keyboard to the port in thought was down and it did not recognize the device. I wonder if this issue is my board or the case. :/
 

scrappy

Patron
Joined
Mar 16, 2017
Messages
347
Can someone suggest another case to me that will not have this issue?
I would think it's more likely a USB header on your Motherboard which connects to your case USB port took a crap unless your case USB ports are part of a USB hub before connecting to the MoBo. Hardware failures will happen regardless the brand of Motherboard or case. Unless parts of your hardware are known to have defects in the USB, it sounds to me you just happened to buy a faulty part.
 

Estropelic

Contributor
Joined
Feb 8, 2016
Messages
103
I would think it's more likely a USB header on your Motherboard which connects to your case USB port took a crap unless your case USB ports are part of a USB hub before connecting to the MoBo. Hardware failures will happen regardless the brand of Motherboard or case. Unless parts of your hardware are known to have defects in the USB, it sounds to me you just happened to buy a faulty part.
The same headed controls two USB ports in which one is not working. I need to see if I can run a health test on the mobile. I've read on the interwebs that the fractal nodes are known for having front port issues. Fingers are crossed. I guess I have another q, can I split a USB port between two devices ie:USB keyboard and UPS connection?
 

Redcoat

MVP
Joined
Feb 18, 2014
Messages
2,909

Redcoat

MVP
Joined
Feb 18, 2014
Messages
2,909
Worked OK for me when I was still using USB drives as boot.
 
Status
Not open for further replies.
Top