Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Error messages and help (python36, Iocage, pkg, ports.)

Disund

Newbie
Joined
Dec 11, 2017
Messages
1
Hi. have little problem with my FreeNAS machine.
are beginners in server and FreeBSD. Have most just run plugins but do not work like I wanted so start following different setups found on different forums beginning everything went stable for half a year since I started my FreeNAS machine installed about it a number of times. Now for a tag, I update from 11.1 to 11.1 U1 and nothing seems to proceed well. do not do anything on iocage is unable to find any python 3.6. Then when you have done your own jails setup, you can not start any plugins that are wrong with mtree! and then today, I would see if there was any updating, then I got the wrong one there to miss Python 3.6 again.

Error messages are linked to the bottom of the page

and a question to how to do this? (The FreeBSD source tree must be located at $ SRC_BASE (/ usr / src by default) to build from git.)

excuse my bad spelling in English

Thank you in advance for all the tips and advice

SINCERELY


and late that it always announces that
Code:
freenas daemon [3742]: 2018/02/02 13:26:54 [WARN] Agent: Check 'freenas_health' is now warning (spam every two minutes)

python3.6: dnssd_clientstub DNSServiceRefSockFD called with invalid DNSServiceRef 0x81fe1a120 FFFFFFFF DDDDDDDD
Feb  2 11:14:35 NASty python3.6: dnssd_clientstub DNSServiceRefSockFD called with invalid DNSServiceRef 0x81fe1a120 00000000 00000000
Feb  2 11:14:35 NASty python3.6: dnssd_clientstub DNSServiceProcessResult called with invalid DNSServiceRef 0x81fe1a120 00000000 00000000
 

donEddie7

Neophyte
Joined
Jun 29, 2016
Messages
9
python3.6: dnssd_clientstub DNSServiceRefSockFD called with invalid DNSServiceRef 0x81fe1a120 FFFFFFFF DDDDDDDD
Feb 2 11:14:35 NASty python3.6: dnssd_clientstub DNSServiceRefSockFD called with invalid DNSServiceRef 0x81fe1a120 00000000 00000000
Feb 2 11:14:35 NASty python3.6: dnssd_clientstub DNSServiceProcessResult called with invalid DNSServiceRef 0x81fe1a120 00000000 00000000[/code]
Were you able to get this fixed? I'm getting the same errors and I'm not sure how to fix it. Recently, i had to change my network to where all my IPs went from 192.168.1.x to 192.168.7.x. I was having issues originally with jails not working but was able to fix them by updating the DNS manually per jail. But I'm still getting these errors on boot. I'm assuming somewhere, it's still using the old DNS Server 192.168.1.1 but it needs to be changed to 192.168.7.1. But I don't know where to look to fix this. This thread seems relatively dead but I'm hoping someone will have more info.

Thanks.
 

donEddie7

Neophyte
Joined
Jun 29, 2016
Messages
9
Were you able to get your jails working?
I'm having the same issue as the OP. Not sure if you were going to offer help or if you were having the same issue but I figured I'd ping you just in case you were able to help. Thanks.
 

Jost Wittmann

Member
Joined
Feb 23, 2014
Messages
32
I too have this issue in FreeNAS 11.2:
Code:
Apr 11 06:54:05 Jonas python3.6: dnssd_clientstub DNSServiceRefSockFD called with invalid DNSServiceRef 0x81b2d4240 00000000 00000000


Through the web-interface of FreeNAS I have inserted into the configuration of the dynamic DNS service:
Server: icanhazip.com:80
Check Path: /.

My provider is No-ip.com.

Any idea how to troublehoot this?
 

Jost Wittmann

Member
Joined
Feb 23, 2014
Messages
32

Kris Heslop

Member
Joined
Feb 7, 2016
Messages
32
Good morning to everyone. While I have been using FreeNAS since early 2016 and know my way around computers fairly well, I still feel a noob on stuff under the hood. If I need to post other logs, please direct me to a resource tha steps me through where andhow to access, since I don't recall seeing anyhing on the past that stepped me through in a way I could follow.

I have been having this problem occur as well, and have searched the forums and google and find several unresolved threads that address this, but none so far that show how it was resolved.

I seem to recall this starting after shortly I upgraded to 11.x and the prior boot device went bad on me...when I replaced with the new flash drive, and it has continued through the latest release 11.2-U5.

I recently changed from IP range 192.168.2.x to 192.168.6.x, and now Plex has stopped running in a legacy jail. I noticed this morning's reboot showed something along the lines of "...Plex...resource deadlocked" When I went to the panel, I was not able to find anything in that data, only what I saw on the screen on boot up....

Last night I was unable to access SMB shares after attempting add a test data set and share for the drive I want to add and reconfigure my 4TB array with 4 discs since I have run out of space for my media. Only my TimeMachine shares showed. I rebooted and still not able to access.

I am running a Lenovo ThinkServer TS140 with:
i3-4130 @ 3.4 GHz (2 Cores with hyper threading)
12 GiB of Hynix Memory ECC DDR3-12800
Intel Pro/1000 7.6.1-k1 GB NIC (not using the motherboard NIC currently) which show s in boot log as:

Jul 2 08:36:40 HeslopNAS em1: <Intel(R) PRO/1000 Network Connection 7.6.1-k> port 0xe000-0xe01f mem 0xf7c20000-0xf7c3ffff,0xf7c00000-0xf7c1ffff irq 17 at device 0.0 on pci2

Boot Drive is a Sandick Ultra Fit (USB3 16 GB, repalced shortly after upgrade to FN 11))
1 - WD Red 3TB
3 - 4 TB Raid Z1 (2-4TB WD Reds and 1-HGST 4 TB NAS Drive)
1 - WD Red 4TB (Getting ready to add to the above group, but want to resovel other issues first).

I have been getting the following python 3.6 error messages for over a month on boot and at other times:


Code:
Jul  2 08:36:52 HeslopNAS kernel: em1: link state changed to UP
Jul  2 08:37:00 HeslopNAS dhclient: New IP Address (em1): 192.168.6.3
Jul  2 08:37:00 HeslopNAS dhclient: New Subnet Mask (em1): 255.255.255.0
Jul  2 08:37:00 HeslopNAS dhclient: New Broadcast Address (em1): 192.168.6.255
Jul  2 14:37:00 HeslopNAS python3.6: dnssd_clientstub DNSServiceRefSockFD called with invalid DNSServiceRef 0x81bc20940 FFFFFFFF DDDDDDDD
Jul  2 14:37:00 HeslopNAS python3.6: dnssd_clientstub DNSServiceProcessResult called with invalid DNSServiceRef 0x81bc20940 00000000 00000000
Jul  2 08:37:00 HeslopNAS dhclient: New Routers (em1): 192.168.6.1
undefined

Code:
port 0xe000-0xe01f mem 0xf7c20000-0xf7c3ffff,0xf7c00000-0xf7c1ffff irq 17 at device 0.0 on pci2


Last night I attempted to add a SMB Share, but it would not show on my network, so I shut things down and rebooted this morning gettign the following...

Code:
Jul  2 00:53:56 HeslopNAS collectd[3792]: rrdcached plugin: Failed to connect to RRDCacheD at unix:/var/run/rrdcached.sock: Unable to connect to rrdcached: No such file or directory (status=2)
Jul  2 00:53:56 HeslopNAS collectd[3792]: rrdcached plugin: Failed to connect to RRDCacheD at unix:/var/run/rrdcached.sock: Unable to connect to rrdcached: No such file or directory (status=2)
Jul  2 00:53:57 HeslopNAS syslog-ng[9785]: syslog-ng shutting down; version='3.20.1'
Jul  2 06:53:57 HeslopNAS /middlewared[240]: dnssd_clientstub DNSServiceProcessResult called with DNSServiceRef with no ProcessReply function
Jul  2 06:53:57 HeslopNAS /middlewared[240]: dnssd_clientstub DNSServiceProcessResult called with DNSServiceRef with no ProcessReply function
Jul  2 06:53:57 HeslopNAS /middlewared[240]: dnssd_clientstub DNSServiceProcessResult called with DNSServiceRef with no ProcessReply function
Jul  2 06:53:57 HeslopNAS /middlewared[240]: dnssd_clientstub DNSServiceProcessResult called with DNSServiceRef with no ProcessReply function
Jul  2 06:53:57 HeslopNAS /middlewared[240]: dnssd_clientstub DNSServiceProcessResult called with DNSServiceRef with no ProcessReply function
Jul  2 06:53:57 HeslopNAS /middlewared[240]: dnssd_clientstub DNSServiceProcessResult called with DNSServiceRef with no ProcessReply function
Jul  2 06:53:57 HeslopNAS /middlewared[240]: dnssd_clientstub DNSServiceProcessResult called with DNSServiceRef with no ProcessReply function
Jul  2 06:53:57 HeslopNAS /middlewared[240]: dnssd_clientstub DNSServiceProcessResult called with DNSServiceRef with no ProcessReply function
Jul  2 06:53:57 HeslopNAS /middlewared[240]: dnssd_clientstub DNSServiceProcessResult called with DNSServiceRef with no ProcessReply function
Jul  2 06:53:57 HeslopNAS /middlewared[240]: dnssd_clientstub DNSServiceProcessResult called with DNSServiceRef with no ProcessReply function
Jul  2 08:36:40 HeslopNAS syslog-ng[2503]: syslog-ng starting up; version='3.20.1'
Jul  2 08:36:40 HeslopNAS Copyright (c) 1992-2018 The FreeBSD Project.


Any help greatly appreciated.

Kris
 

Kris Heslop

Member
Joined
Feb 7, 2016
Messages
32
Thanks for asking, not really able to resolve.

I have only been able to get the SMB shares to work, by turning off the server and waiting until the next morning. I read online in one place that having the system log on a non-boot disc could cause something to go off, and changed that, but thought that was questionable...

All other issues still remain:
-Plex is now running, confirmed in legacy interface, but not accessible on my Mac, Roku, or web browser on Windows machine, but it is showing in the Network places on only the Windows machine. (I don't think I was actually able to get any further response from it, although I was able to ping the IP and get a response.)
-Python error still shows (rebooted to confirm, one of the error strings is posted below.)

Code:
Jul 10 02:39:15 HeslopNAS python3.6: dnssd_clientstub DNSServiceRefSockFD called with invalid DNSServiceRef 0x81bc2da00 FFFFFFFF DDDDDDDD
Jul  9 20:39:15 HeslopNAS dhclient: New Subnet Mask (em1): 255.255.255.0
Jul 10 02:39:15 HeslopNAS python3.6: dnssd_clientstub DNSServiceRefSockFD called with invalid DNSServiceRef 0x81bc2d940 FFFFFFFF DDDDDDDD
Jul 10 02:39:15 HeslopNAS python3.6: dnssd_clientstub DNSServiceRefSockFD called with invalid DNSServiceRef 0x81bc2d6a0 FFFFFFFF DDDDDDDD


I just noticed that the time stamp is flipping, from what looks like system time to GMT time and back several times during the boot log?

So still uncertain what is the cause and what is(are) the related impact(s.)
 

Kris Heslop

Member
Joined
Feb 7, 2016
Messages
32
I notice that after a few upgrades these error messages are still showing up frequently.

Unlike before, the Plex and everything else seems to work fine...so not certain what the cause or impacts are, any ideas or suggestions welcomed?

Code:
Dec 27 17:02:40 HeslopNAS python3.6: dnssd_clientstub DNSServiceRefSockFD called with invalid DNSServiceRef 0x81fa1a900 00000000 00000000
Dec 27 17:02:40 HeslopNAS python3.6: dnssd_clientstub DNSServiceRefSockFD called with invalid DNSServiceRef 0x81e250a20 FFFFFFFF DDDDDDDD
Dec 27 17:02:40 HeslopNAS python3.6: dnssd_clientstub DNSServiceRefSockFD called with invalid DNSServiceRef 0x81e2506c0 FFFFFFFF DDDDDDDD
Dec 27 17:02:40 HeslopNAS python3.6: dnssd_clientstub DNSServiceRefSockFD called with invalid DNSServiceRef 0x81e2505a0 FFFFFFFF DDDDDDDD
Dec 27 17:02:40 HeslopNAS python3.6: dnssd_clientstub DNSServiceRefSockFD called with invalid DNSServiceRef 0x81e250660 FFFFFFFF DDDDDDDD
Dec 27 17:02:40 HeslopNAS python3.6: dnssd_clientstub DNSServiceRefSockFD called with invalid DNSServiceRef 0x81e250960 FFFFFFFF DDDDDDDD
Dec 27 17:02:40 HeslopNAS python3.6: dnssd_clientstub DNSServiceProcessResult called with invalid DNSServiceRef 0x81fa1a900 00000000 00000000
 
Top