Debug (Kernel?) Crash during Disk Import?

Not open for further replies.


Jan 12, 2018
First off, I am a complete FreeBSD novice. I am fairly competent with Linux, but FreeBSD is more different than I thought.

We have an old drive with some data on it that we'd like to copy on to the ZFS pool we have on the server. I haven't figured out how to mount the drive so we just tried importing the disk. We got about 100G in when it appears to crash the kernel. I am fairly certain it is caused by this drive as I've had a pretty stable system going up until now and it happens within 1 minute of initiating the disk import now (I tried restarting it a couple times).

I would love some help/advice on how to debug what is going on or some advice on how to mount the disk. I don't know the format of that partitions in the disk as it was made by someone else.


Hall of Famer
Aug 16, 2011
There's a whole lot of information missing here, most of it covered by the forum rules that you said you read and agreed to when you joined yesterday. But let's start with:
  • Hardware information (motherboard, CPU, RAM, number/type/capacity of disks, disk controller if any)
  • FreeNAS version
  • Output of zpool import
  • Output of zpool status
  • Output of gpart show
  • How are you trying to import the pool?
  • What exactly happens when you try? What error messages are shown, etc.?
Output from the commands above should be in code tags (the "code" button above).
Not open for further replies.