Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Creating a Share for User Home Folders (Mac)

Western Digital Drives - The Preferred Drives of FreeNAS and TrueNAS CORE
Status
Not open for further replies.

strikeing_789d

Junior Member
Joined
Apr 7, 2017
Messages
13
UPDATE: It seems I just need to allow permission for the group that my LDAP users are in to access the share(NAS). Trying to do so results in a "you do not have the necessary permissions" any ideas ? Thanks.



Hi everyone Im on a fresh install of freeNAS however I already have users on my Mac Sever for LDAP. All I am trying to do is have the users authenticate through the already running Mac server like normal but have their home folders stored on the NAS. Sounds simple enough but..... no :( I successfully got the server to see and log into the freeNAS and I can copy files there easily. However I set up a test user and tried to make a home folder directory on the share and it basically says access denied. Which is true. I have set everything on the freeNAS side to full permissions and nothing....... it will not let me access the drive(share) when I try to create a home folder. I can manually put the home folder there of course but what use is that if LDAP cannot access it after authentication.

I think my problem is where it says "everyone" no access when I "get info" on the share, server side. I have no idea how to change it and when I do try to change it to "read and write" it says I do not have permission. I am so stuck.

Someone help me move in the right direction or let me know how to achieve the same thing in a different way. (No I will not transfer all of my users and remake logins to the freeNAS)
 
Last edited:

anodos

Sambassador
iXsystems
Joined
Mar 6, 2014
Messages
7,289
Hi everyone Im on a fresh install of freeNAS however I already have users on my Mac Sever for LDAP. All I am trying to do is have the users authenticate through the already running Mac server like normal but have their home folders stored on the NAS. Sounds simple enough but..... no :( I successfully got the server to see and log into the freeNAS and I can copy files there easily. However I set up a test user and tried to make a home folder directory on the share and it basically says access denied. Which is true. I have set everything on the freeNAS side to full permissions and nothing....... it will not let me access the drive(share) when I try to create a home folder. I can manually put the home folder there of course but what use is that if LDAP cannot access it after authentication.

I think my problem is where it says "everyone" no access when I "get info" on the share, server side. I have no idea how to change it and when I do try to change it to "read and write" it says I do not have permission. I am so stuck.

Someone help me move in the right direction or let me know how to achieve the same thing in a different way. (No I will not transfer all of my users and remake logins to the freeNAS)
Post a debug file or PM it to me (the latter option is preferable if you want to protect sensitive information). "system" -> "advanced" -> "save debug"
 

strikeing_789d

Junior Member
Joined
Apr 7, 2017
Messages
13
Post a debug file or PM it to me (the latter option is preferable if you want to protect sensitive information). "system" -> "advanced" -> "save debug"
The screen shot is what happens when ever I try to add a group and or edit the permissions below. (server side)

Tar file was not accepted so I made it a .zip hope that is ok.

Thank You
 

Attachments

strikeing_789d

Junior Member
Joined
Apr 7, 2017
Messages
13
I already have a Mac share I Mentioned that above in my original post I can read and write files to the NAS no problem. The issue is I CAN but the system (server) cannot because permissions are not correct. All I am trying to do is have my network users home folders on the NAS. I know what I need to do I just do not know how on FreeNAS. I need to add my network users entire "group" to the read and write permissions on the share, and when I try I, get an error which I described above stating I do have the right permissions.
 
Status
Not open for further replies.
Top