Correct settings for Power Management?

Status
Not open for further replies.

jb77

Cadet
Joined
Dec 30, 2011
Messages
2
I currently have 4 drives in a ZFS 'stripe' configuration - however when copying files to my NAS (HP Microserver N40L), or trying to play fiels from the NAS, these drives KEEP spinning up and down - I believe that this is because my power management settings are incorrect

My current settings, for all 4 drives, are:

HDD Standby: 10
APM - Level 64

What settings should I use so that my power management works PROPERLY? - In addition to slowing things down, I am worried that my drives spinning up and down every few seconds will damage them

Thanks
 

jonnyfive

Cadet
Joined
Mar 18, 2012
Messages
4
I was having this problem too with 6 Samsung HD204UI in RAIDz2 in FreeNAS 8.0.4. Not sure what drives you have but have a look over here: http://sourceforge.net/apps/phpbb/freenas/viewtopic.php?f=65&t=9126

To summarize that thread: It appears the HDD Standby and APM functionality are mutually exclusive in practical use. That is if you enable APM on the drive, you let the the drive firmware manage power state, and these consumer green drives (At least the WD and Samsung) apparently have very aggressive Power Management algorithms which cause the drives to spin up and down constantly in FreeNAS RAID.

I disabled the APM on all my drives in my ZFS volume and now they respect the HDD Standby Parameter and don't spin up and down constantly.

-j5
 

StephenFry

Contributor
Joined
Apr 9, 2012
Messages
171
If you have WD drives, use the WDIDLE3 tool with the S=300 parameter to set the read/write head parking to 5 minutes.
 

NASbox

Guru
Joined
May 8, 2012
Messages
644
Thanks jonnyfive - You saved my bacon after spending a couple of hours messing around with power settings ... this point belongs in the user guide and/or release notes.
 
Status
Not open for further replies.
Top