Change AFP permissions .....

Status
Not open for further replies.

ObiTobi

Patron
Joined
Jul 12, 2013
Messages
316
Hi,

long time ago I mean 3-4 years I had some Windows and Macs machines. Windows always connected via CIFS, Macs via AFP. Than some updates (years) later I have again a Mac in my network. I have never changed permissions to AFP shares but don't work correctly anymore.

1. I can connect to share via AFP
2. I can create a file in all directories (bash or finder)
3. I can create a new directory with finder but am always asked for Password. With bash not possible - permission denied

Now is the big question - how can I change the permissions for AFP without affecting those for CIFS?
 

Attachments

  • Permissions.png
    Permissions.png
    103.4 KB · Views: 340
Joined
Jul 3, 2015
Messages
926
Need a bit more info. Is the dataset in question a Windows dataset with Windows permissions? Is it shared via SMB and AFP? What permissions are set on the dataset and how did you set them i.e. via the UI or via a Windows client?

Finally can't the Mac just connect via SMB and if so does that make things better?
 

ObiTobi

Patron
Joined
Jul 12, 2013
Messages
316
Hi,

I'm sorry but I have no any message received about your answer

Yes- it's a SMB, AFP and NFS Share.
Permissions I mean are set with Windows Client.
Ans yes I can connect my Macs via SMB and all it's fine. But I mean file copy operations from Share to Mac or from Mac to Share are much faster via AFP than CIFS


Gesendet von meinem SM-G920F mit Tapatalk
 
Joined
Jul 3, 2015
Messages
926
copy operations from Share to Mac or from Mac to Share are much faster via AFP than CIFS
I guess the first thing to say is that its never a good idea to share the same dataset via multiple different protocols. Secondly I would investigate why you find AFP much faster than SMB and I would begin with looking at disabling SMB3 signing on the apple client machine to improve speeds.
 

ObiTobi

Patron
Joined
Jul 12, 2013
Messages
316
Do you know how I can disable the Signing on my Macs?

Gesendet von meinem SM-G920F mit Tapatalk
 
Joined
Jul 3, 2015
Messages
926
Disconnect your network share.

From terminal:

sudo -s

echo “[default]” > /etc/nsmb.conf

echo signing_required=no >> /etc/nsmb.conf

exit

re-connect.
 

ObiTobi

Patron
Joined
Jul 12, 2013
Messages
316
I will check it next week when I'm back home

Gesendet von meinem SM-G920F mit Tapatalk
 
Status
Not open for further replies.
Top