Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

SOLVED Cannot apply ACL to dataset


Dec 19, 2019
First, my setup: I'm running freenas 11.3, joined to a Windows2019 AD. I have a pool with datasets.
An AD user and an AD group both had full access to this dataset via ACL settings.

After a reboot, my root password no longer worked, and after I reset it, all my configured shares were gone.
When trying to set them up again, I ran into this error message:

"Error: [dacl] Item#2 is not valid per list types: [id] Not an integer "


Actually, now that I tried again, I get this error instead:


This appears for any AD user or group I try to add to the ACL list. I can change and save permissions for group@ and owner@.

EDIT: For some reason I got it to work, with as far as I can tell the same steps...
I repeated my steps a dozen times and it didn't work. Then I made a new dataset, and applied the same settings to it that gave me uid error before; one user, one group, default acls with full control. On the new dataset it worked.
After that I tried again on my old dataset, and now that works as well.

Sorry for making this empty thread I guess, I have no idea how this happened or why it works now. I also still don't know why my password and config were gone after a reboot. thank you for your time.
Last edited: