Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

SOLVED bhyve console weirdness

Status
Not open for further replies.

KBKB

Cadet
Joined
Jul 24, 2017
Messages
2
I updated to FreeNAS-11.0-U2 earlier today. Prior to that I had been running FreeNAS 9.something and then FreeBSD 11 (which I had installed on another disk).

I had a number of bhyve VMs (located on a ZFS volume) which I wanted to continue to use. I was able to use "iohyve list" to verify that they were there, but was not able to make them start. After attempting to start them a few times, I decided to check the console via "iohyve console VM-Name". I'd hit return and see a "grub> " prompt (which was expected). However, when I'd type something at the prompt, only some subset of the charactes that I typed were seen by bhyve-grub. E.g...

Code:
grub> configfile (hd0,msdos1)/grub.cfg
error: can't find command `1/.cfg'.
grub>
error: can't find command `onfigfile'.
grub>


It turned out that more than one grub-bhyve process was being created for the VM that I was trying (and failing) to start. These processes would take turns grabbing a few characters which resulted in the unknown commands shown above.

From one of my earlier experiences with iohyve, I remembered that I had created a symbolic link from /mnt/iohyve to /iohyve:
Code:
ln -sn /mnt/iohyve /iohyve

Once I did that, I was able to start my VMs. There were still some excess bhyve-grub processes, however, which were playing havoc with the iohyve consoles. I was able to kill them off, which sort of worked, but things were left in a weird state; a reboot fixed that.

So... the fix (for me) was to create that symlink and then reboot. It's not clear to me if this is required for a fresh FreeNAS 11 install.

I hope that this is of help to someone else...
 
D

dlavigne

Guest
It would be worthwhile to report the multiple processes at bugs.freenas.org. If you do, post the issue number here.
 
Status
Not open for further replies.
Top