Anyone else notice the TrueNAS web GUI is... "clunky"?

Oct 22, 2019
This not not a technical question, nor a formal bug report. It's a semi-rant and I'm wondering if others have noticed this as well.

With TrueNAS Core 13.0-U2 (and even previous versions of this "stable" appliance), I've bumped into several instances where the GUI just... farts.

It's quite unnerving, and I lay the blame on the middleware/GUI itself, not ZFS nor FreeBSD nor Linux.

Some uncomfortable "farts" that happened when trying to use the web GUI as it was intended (i.e, just standard stuff; not doing anything considered "off the mark"):

  • Sometimes physical drives are listed under Storage > Disks, and other times they're not. (Mostly USB drives.)

  • Sometimes S.M.A.R.T. buttons are not shown under a drive, and sometimes they are.

  • Deleting a test dataset with the GUI (which was also created with the GUI) the circle just spins and spins and spins and spins. After nearly 10 minutes of this frozen GUI, I closed the web browser and tried to log back into TrueNAS. The login page said it could not connect to the server. However, I could SSH into the server. I could still view the pools with "zpool status". Yet the GUI was unavailable. I tried restarting the middlewared service. Still cannot login to the GUI. I restarted the server from the SSH terminal, and upon reboot, lo' and behold, the dataset is gone! (So why on earth did the GUI just keep spinning the circle indefinitely when the task likely completed within a couple of seconds?) To make matters worse, it's rare and random, yet unclear why it farts when it does.

  • Statuses of Jails (when viewed in the GUI) don't update unless you forcefully refresh the page. (So for example, doing a bulk start for multiple jails will still show their status as "down", unless you refresh or revisit the page. Checking with "iocage list" reveals they are in fact "up".) However, the status properly updates if you use the "Start" button on a specific Jail, without selecting any Jails' checkbox.

  • The "Alerts" menu keeps shoving in my face the stupid "warning" about "new features are available for your pools". Leave me alone. I already dismissed it. Just because I import/export one pool, doesn't mean you need to annoy me about upgrading the features on my other pools every single time. Leave such a suggestion in each individual pool's status page. Don't make it an "Alert" that requires the user's attention.

  • Adjusting the width of columns is still clunky, as it has been for the longest time. Seriously. Try it now. Go to a page, such as SMB Shares, and use your mouse cursor to adjust the widths of the columns. You'll notice it acts random and doesn't respect how narrow you want certain columns to be. It feels like playing with stubborn rubber bands.

  • Not listed here in this semi-rant are other random hiccups and farts when using the GUI as intended. I just don't log every time something happens, which brings me to... the underlying technology that powers the GUI/middleware old in the tooth? It doesn't feel as "snappy" compared to other web GUIs I've used. I get nervous that I'll be struck by the "Please wait" spinning circle again, which will require another reboot. It haunts me in my dreams.


To be clear, the same usage of zfs/zpool commands are super snappy, responsive, and with zero issues in the command-line; which also holds true with a Linux distro on a weaker machine. That's why I don't chalk this up to hardware errors. I've noticed it exclusively with the middleware / web GUI.

Yes, it's "rare" to an extent, but still concerning since I view TrueNAS as a stalwart appliance.

Last edited: