Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Warnings encountered when extending RAID0 pool

be7taname

Junior Member
Joined
Jan 12, 2021
Messages
12
My freenas has a pool which consists of two 5TB disks in RAID0 (no raid basically) shown below.
Current Status.JPG


I am trying to extend this pool, so I added two 8TB disks into the machine.
First I extended the pool with one 8TB disk and I got the warning "You are trying to add a virtual device consisting of 1 device(s) in a pool that has a virtual device consisting of 2 device(s)" as shown below.
warning1.JPG


Therefore, I added the 2nd 8TB disk into the new vdev. However, I got one more warning "Adding data vdevs with different numbers of disks is not recommended. First vdev has 1 disks, new vdev has 2." on top of the previous warning as shown below.
warning2.JPG


I am totally confused by the 2nd warning since my current vdev, as shown in the 1st picture, consists of two disks.
Please advise how I could extend my pool safely. Thanks in advance!
 

sretalla

Wizened Sage
Joined
Jan 1, 2016
Messages
4,084
I don't doubt that the wording of the warnings wasn't considering the case of a striped pool when trying to help people to accidentally not add a VDEV of the wrong type into a pool with existing VDEVs.

You can log a ticket in jira if you think it's really impossible to understand.

A quick set of tests on my end show that the pool correctly becomes a stripe of 4 single-disk VDEVS when adding 2 to an existing 2 despite the strange warning.
 

be7taname

Junior Member
Joined
Jan 12, 2021
Messages
12
Thanks @sretalla ! If that's the case, I will just ignore the warning. Could you please help to do another test to see if it becomes a stripe of 3 disks VDEV when adding 1 to an existing 2 if not too troublesome for you? Many many thanks!
 

sretalla

Wizened Sage
Joined
Jan 1, 2016
Messages
4,084
It does.
 

be7taname

Junior Member
Joined
Jan 12, 2021
Messages
12
Thank you so much for the quick response and great help, @sretalla !
I tried to add 1 disk but the freenas simply wouldn't let me to go through.
So I added 2 disks and it worked. Again, I really appreciate your help!
 

sretalla

Wizened Sage
Joined
Jan 1, 2016
Messages
4,084
I tested on 12.0-U2. Maybe your different experience was from another version.
 

be7taname

Junior Member
Joined
Jan 12, 2021
Messages
12
Yes, I am using a different version FreeNAS-11.2-U7. It could be the reason. I was stuck in a infinity loop of "Confirm" and "Warning".
 
Top