Update to 11.1 Stable Missing Datasets in GUI still Accessible

Not open for further replies.


Dec 14, 2017

I ran the update without any major upsets a couple days ago and have now found that some of my datasets aren't coming up in the GUI. It's odd because I had no problem rebuilding my Plex jail and mounting the necessary directories (sharing service working fine, I can still 'see' the data from other machines). I read and saw that detaching the volume and importing it manually may help. When I tried, I got a middleware error. I copied the output and put it in a .txt attached here. Volume is encrypted, but unlocks fine with geli.key and passphrase. I just can't access the dataset from the GUI to change permissions and such. I'm sort of afraid to mess with it much more until I get another few HDDs in and can do a local backup - too much data for my client machines to take in.

I plan to: (1) set up another raidz1 and a small ssd (unencrypted - especially for jails omg what a mistake to put them on the encrypted volume) and create another pool. (2) Copy the data over via a windows machine. (3) Reassign my SMB share to the new volume and dataset. (4) bugger around with the original. I'll feel much safer doing so.

I'm super new to Unix and have to look up every command as I use them. Any help greatly appreciated. Any links to a Unix/FreeBSD manual and tutorial for academia would be great as well. The forum stuff leaves out a lot of example text and modifier purpose/use cases.

Thank you Thank you!!

Request Method:	POST
Request URL:
Software Version:	FreeNAS-11.1-RELEASE (dc7d195f4)
Exception Type:	MiddlewareError
Exception Value:	
[MiddlewareError: Failed to remove mountpoint /mnt/NAS_Media: [Errno 66] Directory not empty: '/mnt/NAS_Media']
Exception Location:	./freenasUI/middleware/notifier.py in __rmdir_mountpoint, line 2743
Server time:	Fri, 15 Dec 2017 05:25:19 -0700


Software Version: FreeNAS-11.1-RELEASE (dc7d195f4)
Request Method: POST
Request URL:

File "./freenasUI/middleware/notifier.py" in __rmdir_mountpoint
  2740.					 os.rmdir(path)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/exception.py" in inner
  42.			 response = get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _legacy_get_response
  249.			 response = self._get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _get_response
  178.			 response = middleware_method(request, callback, callback_args, callback_kwargs)
File "./freenasUI/freeadmin/middleware.py" in process_view
  162.		 return login_required(view_func)(request, *view_args, **view_kwargs)
File "/usr/local/lib/python3.6/site-packages/django/contrib/auth/decorators.py" in _wrapped_view
  23.				 return view_func(request, *args, **kwargs)
File "./freenasUI/storage/views.py" in volume_detach
  714.					 cascade=form.cleaned_data.get('cascade', True))
File "./freenasUI/storage/models.py" in delete
  390.				 systemdataset=systemdataset,
File "./freenasUI/storage/models.py" in _delete
  371.			 n.volume_detach(self)
File "./freenasUI/middleware/notifier.py" in volume_detach
  2604.		 self.__rmdir_mountpoint(vol_mountpath)
File "./freenasUI/middleware/notifier.py" in __rmdir_mountpoint
  2743.									   % (path, str(ose), ))

Exception Type: MiddlewareError at /storage/detach/1/
Exception Value: [MiddlewareError: Failed to remove mountpoint /mnt/NAS_Media: [Errno 66] Directory not empty: '/mnt/NAS_Media']

Variable	Value
sessionid	'gbuuacb40qttyrswd9q1gzq9d84kfxnt'
csrftoken	'Drm736soMlurGfMufXKwd4B6PMzphQ1lgmnWH4kojeRw2vsJKuKUdFmazEjZ7xUc'
fntreeSaveStateCookie	'root%2Croot%2F182%2Croot%2F162%2Croot%2F194%2Croot%2F194%2F200%2Croot%2F194%2F204%2F206%2Croot%2F194%2F204%2Croot%2F1%2F2%2Croot%2F1%2F9%2Croot%2F1%2F8%2Croot%2F68%2Croot%2F68%2F69%2Croot%2F68%2F69%2F70'
Variable	Value



  • FreeNas Error_Detach Volume.txt
    2.6 KB · Views: 246
Last edited:


FreeNAS Enthusiast
Oct 6, 2013
I copied the output and put it in a .txt attached here
You may use the code tags provided within the text window and post the copied messages directly into your post.
Most members prefer this to clicking on, then downloading a document.


wrt the traceback, please create a report at bugs.freenas.org and post the issue number here.
Not open for further replies.