Unable to connect to an Active Directory authenticated SMB share from linux box

Not open for further replies.


Jun 21, 2018
I am able to connect to a guest share without a problem from linux but am unable to authenticate to a authenticated share. I have tried the following commands:

mount -t cifs -o guest //nas/temp /mountest <-- This one works as this temp share I created is open to guest

mount -t cifs -o user=myuser,domain=mydomain //nas/usershare /mymountpoint <-- With this I get

Jun 21 14:02:09 ndruser-System-Product-Name kernel: [12253.535323] No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3 (or SMB2.1) specify vers=1.0 on mount.
mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
Jun 21 14:02:10 : [12255.166949] Status code returned 0xc0000022 STATUS_ACCESS_DENIED
Jun 21 14:02:10 : [12255.166956] CIFS VFS: Send error in SessSetup = -13
Jun 21 14:02:10 l: [12255.166964] CIFS VFS: cifs_mount failed w/return code = -13

I have tried multiple variations of the mount -t cifs -o such as including the user without the domain, including the password with the password= option and so on. They all seem to produce the STATUS_ACCESS_DENIED error.

I am able to map to this share without a problem with the same credentials in windows.
Not open for further replies.