Unable to browse CIFS from Linux When Source Directories exceed 365 directories

Not open for further replies.


Jun 29, 2011
To all

I discovered something interesting about the CIFS share and the solution.

I'm using FreeNAS 8.01 Beta4. I have a CIFS (or samba) shared directories of more than total of 365 number of directories.

In Win7, I can view the shared directories without any problem. Can read and write.
When come to openSUSE 11.4 (it is samba 3.5.7), I can mount (using mount -t cifs) the CIFS directories and view the shared directories. But when I use "dolphin" or "konqueror" (using smb:// protocol) or smb4k to view the shared directories, I unable to view it. The openSUSE prompt me either the shared directory not exists or it keep on querying and no result return.

When I remove/moved the some of the directories in the CIFS share to another directories/dataset, when the total directories reaches 364 or less, I can view the contents using konqueror or dolphin.

I tried reset my FreeNAS system to factory state and reconfigured it again and still the same.

Finally, I try enable "Large RW support" under the CIFS configuration of the FreeNAS. To my surprise, openSUSE now can view the CIFS share directories that contain more than 364 number of directories.

So, to anyone of u who encounter similar problem, do remember to enable the "Large RW support".

Not open for further replies.