Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

True NAS Core 13 installation on IBM X3100M4

Joined
Jun 16, 2022
Messages
4
Hi,

I have IBM X3100M4 Old Server with Xeon E3 Processor ( 4 Core ), 8GB RAM, 1 x 250GB, 1 x 1TB HDD ( for Testing Purpose Only ), I downloaded the latest True NAS Core 13 and start the installation but faced the below error and installation stopped.

"pcib3: acpi pci-pci bridge at device 28.0 on pci0"

"pcib3: failed to allocate initial prefetch windows: 0xc0000000-0xc0ffffff"


what could be the reason?
 

sretalla

Hall of Famer
Joined
Jan 1, 2016
Messages
6,548
Seems to be saying there's an issue with some device on the PCI bus 3...

Can you remove your PCI cards (the ones not necessary for the install disks) and try it again?
 
Joined
Jun 16, 2022
Messages
4
Hi,

No PCI / PCI-E card installed in the server.

tried below commands but did not succeed.

set hint.acpi.0.disabled=1
boot

set hw.pci.realloc_bars=1 and set hw.pci.realloc_bars=3
boot
 

sretalla

Hall of Famer
Joined
Jan 1, 2016
Messages
6,548
Can you install plain FreeBSD 13 on it?
 

sretalla

Hall of Famer
Joined
Jan 1, 2016
Messages
6,548
Seems your system is somehow not compatible with FreeBSD then... maybe you need to look at BIOS settings that may be preventing the install.

Alternatively, you may find more success with TrueNAS scale as it's booted via GRUB, which supports a wider range of hardware.
 

Ericloewe

Not-very-passive-but-aggressive
Moderator
Joined
Feb 15, 2014
Messages
17,770
Might want to start disabling PCI devices in the system firmware until the error goes away, to identify the culprit.
 
Top