Small File Xfer OK, Large File Xfer Errors

Not open for further replies.


Aug 28, 2011
I’ve searched the Internet and this forum for days now and can’t seem to find a solid solution to what appears to be a repetitive issue for several FreeNAS users. I am fairly computer savvy with Windows based PCs, but this is my first attempt at a UNIX-Like FreeBSD type environment so go easy on me.

My new FreeNAS 8 setup went well, but the problem I’m experiencing is I can’t copy large files to the NAS. Example, I can copy a single 500MB file nicely at approx. 98MB/s, but when I test copy a 2GB file it starts out well at the same speed but then slows to around 9.7MB/s and freezes at about the 40% mark. If I wait it out I eventually get a popup error message on the Windows machine as follows:

“There is a problem accessing \\FreeNas\Share. Make sure you are connected to the network and try again.”

From there I can’t access the share or do anything with the NAS Web GUI until I reboot it. Upon reboot I can see that a large amount of the file did get copied (approx. 1.7GB of 2GB), but it is not accessible because it is a partial which makes it corrupt. This test has been repeated with different files and I always get the same result.

I finally decided to duplicate the error but hooked a monitor and graphics card back up to the NAS PC which allowed me to see hundreds of scrolling error messages as follows:

“swap_pager: I/O error - pageout failed; blkno xx,size xx, error 6”

The xx’s represent varying blocks and sizes. The drives are new so just to be safe I checked them all with Data Lifeguard Diagnostic and they seem OK. My NAS setup is straight forward with no tuning and only has a simple Windows share, 1 User and 1 Group. Seeing the share from a Windows PC is not an issue after reboots. My store configuration is ZFS with RAIDZ2, but originally was ZFZ with RAID 10. Either way, both produce the same error when copying a 2GB file. The motherboard does have a built in RAID controller, but it is disable in the BIOS so that I use only 100% of the built in FreeNAS RAID and File System software for management. My home network is Gigabit speed so I do not think there is any issue there.

Of the small clues I have found on the Internet, it was mentioned to change the drives in the BIOS from AUTO to LARGE. I did this and rebuilt the RAID array but got the same result. I have since switched the BIOS back to AUTO just so as to not dink with too many unknown parameters.

My additional system specs are listed below if they help. I’m fairly confident I meet the minimum requirements. I really like FreeNAS and want to make this work, so any help is greatly appreciated. Thank you in advanced…

CPU: Intel Pentium D 2.66GHZ (Cooling- Thermaltake Big Typhoon Cl-P0114 120mm Fan)
RAM: 4GB Corsair CM2x2048-6400C4DHX (2 X 2GB DDR2 800MHZ)
ETHERNET: On Board Intel Gigabit Ethernet Adapter
POWER: Corsair 750w (TX750W)

1 x 4GB SanDisk Cruzer USB 2.0 Flash Drive (Loads FreeNAS)
4 x Western Digital WD20EARS (2 TB Caviar Green SATA II Intellipower 64 MB Cache)

1 x Gigabit Router-CISCO LINKSYS E2000
1 x Unmanaged Gigabit Switch - 16 Port TRENDNET TEG-S16DG
3 x Unmanaged Gigabit Switch - 5 Port TRENDNET TEG-S50G
1 x VOIP Router - MOTOROLA VT2442
1 x Windows 2000 Server (Not involved in NAS share config)
7 x Windows PC (3 Win XP / 4 Win7)
2 x DVR

5 x LAPTOP (Win7)

...and yes this is all at my home.
May 27, 2011
first up, dump your win2k server. it's not supported by MS and there are plenty of unpatched exploits.

Are you running the 32 bit or the 64 bit version of FreeNAS?

What happens when you write a 100 GB file locally with DD? does it complete or fail?

Have you checked out your hardware? memtest, heat, SMART...


Aug 28, 2011
Thanks for the feedback matthewowen01. Since this post, I have resolved my issue. It appears that FreeNAS 8 does not like older Pentium dual cores or single cores with Hyper-threading Technology turned on.

As stated in my OP, I was using an Intel Pentium D, 2.66GHZ. Essentially that is a Pentium 4 with 2 cores. So I yanked a single core Pentium 4, 3.0GHz from another old machine and swapped it out. But, it didn't like that one either. Matter-of-fact, I couldn't even get it to finish loading until I discovered through experimentation to turn off Hyper-threading from within the BIOS.

After that, Viola! Hyper-threading off did the trick. So now I am able to transfer large 2GB or more files at 98MB/s without breaking a sweat as long as my single core Pentium 4 has the Hyper-threading off.

It would be appreciated and helpful if anyone could post a theory as to why? I'd also like to know if I should have completely re-installed FreeNAS from scratch due to the processor change, or should it have detected the new processor OK. At this point things seem fine, but I want to do this correctly before I transfer all my files. Thanks in advanced.
Not open for further replies.