several "minor" problems

Not open for further replies.


Jul 12, 2011
I'll try to list this as logically as possible.

A week ago there was a thunderstorm and my FreeNAS started to act up, I was watching a movie thruogh my HTPC and every 15-25 minutes it dropped the movie and appearantly my FreeNas rebooted. First I thought it was a heating problem because I had just moved my FreeNAS to a more cramped space. I found out pretty quick that it was not the problem, I checked the HW monitor in BIOS after a reboot.

What's weird with this story is that after I finished the movie I restarted it and let it run, and it ran the whole movie without a hitch. I used memtest the day after on every RAM module and 3 out of the 4 had errors. I did try the RAM modules in my HTPC and no errors in memtest there. So RAM modules are working. After that I tried the HTPC's CPU in my FreeNAS and did memtest. Still problems. Also with the HTPC's RAM modules showed errors. So, the problem was tracked down to the MoBo itself.

I tracked down a used MoBo on an enthusiasts market place. Installed it all with drives and my old USB thumb drive with my old OS, everything seemed to work fine but it started to reboot as well. I installed a DVD-rom to the IDE port to boot Ultimate Boot CD to try the RAM here. Seems that the MoBo somehow "short circuited" the IDE DVD-rom drive because as long as the IDE cable was plugged in there was no power to the DVD-ROM, I tried 2 different DVD-ROM and 3 different cable. save problem. I returned the MoBo and got a another 775 socket MoBo from a vendor that had gotten one in return from the shop. Let's just say that didn't work.

Now my HDD and OS thumb drive are plugged into the HTPC instead and are acting FreeNAS. This is where I am now. I'm getting "errors and warnings" when I boot the FreeNAS OS, but some of them doesn't show up on /var/log/messages at the bottom of the gui so I can't list them all if I can't figure out where they are stored.

Some of the Warnings I get are:

I don't think this is serious at all but I thought I'd list it
Warning: No NSS Support  for mDNS detected, consider installing nss-mdns

I'm getting alot of these. Like 15 spread out and some in clusters
Popen()ing: sysctl -b kern.geom.confxml

Also on my two small samsung drives are were in a ZFS mirror before I botched. I thought I did something else when I exported the volume in GUI. they are ada4 and ada5, ada4 doesn't show up in the gui when I try to make a new volume (which I haven't, I was just checking), I can't auto import the volume (called mantis), when I try to do a manual import in the gui, ada4 doesn't show up.
Device: /dev/ada4, WARNING: May need -f samsung3 enabled; see manual for details. 

As long as I can remember this error has always shown up, think it's not important
WARNING: failed precmd routine for vmware_guestd

There is however something that shows up on the console screen when I boot that don't show up on /var/log/messages and it runs past so fast, I'm going to try to film it with a camera and see what it says.

I wouldn't mind just reinstall the OS and set it up all again if it's too much trouble fixing. I did make a new OS thumb drive with RC1, but the log bit that doesn't show up which I just explained I think shows up there too. Also I can't auto import any of the two zfs volumes I had for some reason. I've done some scrubbing and 7 files showed up, all files that were copied to FreeNAS when a faulty MoBo was connected.

This is where I am now and I'm out of ideas of what to do, I'm not good at linux/BSD/etc. My concern most is that my large RAIDZ volume is compromised since I can't auto import it when I tried with my fresh OS. (I'm still running on my old OS btea4 OS)
Not open for further replies.