Same ZFS CHKSUM error after replacing the USB flash boot drive

Not open for further replies.


Jan 17, 2016
I started getting zpool status emails for the freenas-boot pool on my NAS with "31" in the CKSUM column. I replaced that USB drive with a different one of the same type. After about a week, I've started getting these emails again, and strangely, CKSUM is again "31." Has anyone seen this before or is it just a coincidence?

Things I've tried:
  • before replacing the original USB, I ran memtest86 for an hour or two--no memory errors were found.
  • I checked the replacement USB flash drive with ChkFlsh.exe. I ran it in "burn it!" mode for a while and no errors were found.
  • I checked the original USB flash drive with ChkFlsh.exe after replacing it. It also showed no errors.
What else might cause this? The one thing I have not checked is the cable from the motherboard to the USB port (which is inside the case). I suppose there could be a fault with that cable or it may not be seated correctly... but I am a bit skeptical whether that would result in a CKSUM of 31 on two separate USB flash drives.

Does anyone have any recommendations on how I might diagnose and resolve the problem? I know I can try a different USB port, get a new cable, etc. but since the machine in question is not easily physically accessible, if there is a way I can more definitively determine what is going on, that would be great.
Not open for further replies.