Register for the iXsystems Community to get an ad-free experience

SOLVED Problem with perl found but not found during make install in unifi iocage jail [FNAS11.1U6]

Western Digital Drives - The Preferred Drives of FreeNAS and TrueNAS CORE
Status
Not open for further replies.
Joined
Nov 15, 2016
Messages
4
Hello people!

I'd like to ask for a little help from someone more knowledgeable than me.

I've tried creating an iocage jail and installing unifi controler software on it. Been running it in the old jail system up till this evening and decided it would be a good idea to try and set it up as an iocage jail before I eventually decide to upgrade to 11.2. Anyway, what I've done is - I mostly followed the instructions here mixed with the url: "pkg+http://pkg.FreeBSD.org/${ABI}/release_2", solution to the missing libdl.so.1 problem found here and got to the make install clean BATCH=yes ALLOW_UNSUPPORTED_SYSTEM=yes part of the process and then it failed with

Code:
===>   p5-Locale-gettext-1.07 depends on package: perl5>=5.26<5.27 - found
===>   p5-Locale-gettext-1.07 depends on shared library: libintl.so - found (/usr/local/lib/libintl.so)
===>  Configuring for p5-Locale-gettext-1.07
env: /usr/local/bin/perl5.26.3: No such file or directory
*** Error code 127

Stop.
make[6]: stopped in /usr/ports/devel/p5-Locale-gettext
*** Error code 1

Stop.
make[5]: stopped in /usr/ports/misc/help2man
*** Error code 1

Stop.
make[4]: stopped in /usr/ports/print/texinfo
*** Error code 1

Stop.
make[3]: stopped in /usr/ports/devel/m4
*** Error code 1

Stop.
make[2]: stopped in /usr/ports/devel/scons
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/databases/mongodb36
*** Error code 1

Stop.
make: stopped in /usr/ports/net-mgmt/unifi5


I'm running
freebsd-version in jail returns 11.1-RELEASE-p6
freebsd-version in freenas returns 11.1-STABLE

Anybody have any idea what to do? I do need my unifi controller... Thanks in advance.
 

SW77

Dabbler
Joined
Apr 1, 2017
Messages
15
I had no problems installing my controller. I used the following code:
Code:
pkg install unifi5
 
Joined
Nov 15, 2016
Messages
4
I had no problems installing my controller. I used the following code:
pkg install unifi5

Thank you very much. It stupidly never occurred to me to try that solution. :)

In case you're willing and able to help further, I've created a new iocage jail, enabled vnet, set ip address, left everything else at default and installed unifi as you suggested, but now the controller web ui hangs at "UniFi controller is starting up... Please wait a moment." As the title indicates, I'm running FN11.1U6... should I have used url: "pkg+http://pkg.FreeBSD.org/${ABI}/release_2", setting in FreeBSD.conf? Thanks!

EDIT: Tried it out with the setting mentioned above in FreeBSD.conf and it worked. It seems the version that gets installed with the normal "quarterly" setting has the missing libdl.so.1 problem and it seems mongodb doesn't start (can't remember correctly because I skimmed through the log and then deleted the jail to start again)... Installing with the "release_2" setting installs an older version (5.7.23) but at least it seems to be working. Will try it all out again when I gather the balls (and two full backups) to install the 11.2 release. Thanks for your help.
 
Last edited:
Status
Not open for further replies.
Top