Not detecting GLOTRENDS PA40 Quad M.2 NVMe to PCIe 3.0 X8 Adapter with 4 M.2 NVMe installed that was recognized in Core/not Scale (SOLVED)

matsokos

Cadet
Joined
Mar 27, 2024
Messages
1
I'm writing to see if anyone has suggestion on getting Truenas scale to recognize my 4 NVMe SSD's on my new install of TrueNAS-SCALE-23.10.2 that I just installed. I had previously installed TrueNAS Core 13.0-6.1 and was just starting to explore when I saw the option to migrate to TrueNAS Scale with just a download. I did some reading and felt Scale was a good option for me. I had 4 Ironwolf 10 TB drives and 4 NVMe drives installed and working on TrueNAS Core but disappeared after migration. I used the above adapter in the "new" Dell Precision 5810 that I just got. 2 of the drives had worked for me in previous PC's that I had. I deleted all partitions on these NVMe and formatted them. The 2 new NVMe drives were also partitioned and formatted then all 4 were installed in the Server. All seven drives were recognized when the machine was booted in Windows 10 PRO. I initially decided to install TrueNAS Core which after a few attempts at what boot sequence was needed to navigate the BIOS of the Dell. I put together the SSD's into a striped pool of three 2 TB SSD's and one 4 TB drive. I had a hangup in the middle of a Plex Media Server install with the error: RuntimeError Message: No default interface found Partial plugin destroyed. After doing some reading in the forums I decided to completely delete everything I did and reinstall a fresh install of Core which went great. Before I even made one pool, I saw the option to migrate to Scale with just a download and did some more reading about Scale and went ahead with the migration which I thought went fine until I went to make my first pool where I discovered the 4 NVMe SSD were not recognized.
As I stated above my Server is a Dell Precision 5810T with 3 Ironwolf 10 TB HDD and 4 NVMe SSD as above (one 4 TB and three 2 TB SSD} the adapter is the GLOTRENDs PA40 Quad M.2 to PCIe 3.0 x 8 Adapter( below is a screenshot of the adapter info from Amazon and one of my Dashboard. I purchased 4 new A-TECH 32GB RAM Replacement for Micron MTA36ASF4G72PZ-3G2 | DDR4 3200MHz PC4-25600 ECC RDIMM 2Rx4 Server Memory which works great. I also purchased a Acer Predator Graphic Card BiFrost Intel Arc A770 2.20GHz OC which seems to be working fine. when I rebooted the server its been stuck at the attached screen picture 3675. I forced a reboot and was able to take a few photos where I saw the error in 3677 nvme does your device have a faulty power savings mode? I then swapped PCIe lanes with the GPU and rebooted and all was well. Sorry I went on so much but decided to post incase someone else had a similar issue
 

Attachments

  • Screenshot 2024-03-27 203906.png
    Screenshot 2024-03-27 203906.png
    549.1 KB · Views: 46
  • Screenshot 2024-03-27 204124.png
    Screenshot 2024-03-27 204124.png
    176.3 KB · Views: 39
  • 1000003675.jpg
    1000003675.jpg
    307.7 KB · Views: 42
  • 1000003677.jpg
    1000003677.jpg
    374.8 KB · Views: 44
Top