Networking and Kubernetes Problem


Mar 6, 2024
I am running TrueNAS-SCALE- for over half a year now with no problems until recently hosting my HA as VM, plex and adguard as Apps, and my server shares. Plex started having issues with connectivity about a month ago I changed the port number from 32400 (default) to 32500 and it worked ok but then I noticed the titles and posters started to disappear and wouldn't update. I read somewhere that pulling the media out and then re uploading it forces a refresh of meta data and did that and it worked. However, last night me and the wife where watching Dr. Who when suddenly the server went down completely hard crash had to manually power it off. When it started back up Plex refused to start but adguard did (I think) and so did my VM with HA. I just gave up at that point and wiped off Plex to reinstall it fresh but that didn't work I kept getting a networking error on any port I was trying to use failing probe and the VM failed to start. (I don't have this error message anymore becuse it got worse.) I then thought well maybe I need an update on the system but when I went to update the system to TrueNAS- which is what shows in my update page it says
"TimeoutError: TrueNAS was unable to reach update servers." That sent me down a networking rabbit hole where I know networking is working but I can't get TrueNas to see that. I can run NSLookup for and get the same resolve as my other computer. I can ping google from the TrueNas Server and mine but I can not ping from either. I can navigate in a webbrowser to it though so it seems ping is just blocked on that server. I then tried to reset Kubernetes as posted here by changing the advanced settings CIRD by setting it to /16 and checking force. It didn't work so I unset the pool and then tried to reset it but now get this error message.
"Error: [EINVAL] kubernetes_update.force: Apps have been partially initialized on 'Containers' pool but it is missing 'Containers/ix-applications/k3s/kubelet, Containers/ix-applications/releases, Containers/ix-applications/default_volumes, Containers/ix-applications/catalogs' datasets. Specify force to override this and let system re-initialize applications."

I then threw my hands up in the air and went to bed. I am still haveing all the same networking issues and Kubernetes wont even start up. However my HA which is in a VM has full networking and is running just fine so it have to be something with TrueNas. I know my VM can reach the internet becuse my alexa intigration is still working after multiple restarts of the TrueNas system. I have no idea what to do or what logs to pull my searchs have not turned anything quite like what is happning to me.