Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

SOLVED Mounting SMB with Ubuntu: mount error(95)

Maxburn

Junior Member
Joined
Oct 26, 2018
Messages
23
With FreeNAS I'm replacing a Synology that I had mounted via SMB in a Ubuntu 16.04 machine. My fstab used to look like this with the creds stored and locked, worked great
Code:
//192.168.1.21/ds418 /mnt/ds418 cifs credentials=/home/myname/ds418creds,iocharset=utf8,sec=ntlm 0 0

Simply modifying this to the new mounts like this
Code:
//192.168.1.23/freenas /mnt/freenas cifs credentials=/home/myname/freenascreds,iocharset=utf8,sec=ntlm 0 0

Results in this error:
Code:
mount error(95): Operation not supported
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Watched a guy do it on a youtube video with his fstab laid out like this and it worked for him, but I got the same error as above so it feels like something is not right on the FreeNAS side that somehow only impacts Ubuntu connecting but I really don't know.
Code:
//192.168.1.23/freenas /mnt/freenas/ cifs username=username,password=ispassword,rw,iocharset=utf8,noperm 0 0

I have no issue opening \\10.0.1.23\freenas in widnows with the same credentials I'm using in ubuntu. Big question here is why is none of this working with the FreeNAS box??
 

Johnny Fartpants

Neophyte Sage
Joined
Jul 3, 2015
Messages
571
Could be an SMB version thing so try adding vers=3\.0 to your command.
 

Maxburn

Junior Member
Joined
Oct 26, 2018
Messages
23
Thank you, that was it. Which I find concerning on a couple of levels. I guess the default is still some older version and there is no auto negotiation. Also seems Synology is leaving things with the older versions somewhere. For anyone else finding this:

Code:
//192.168.1.23/freenas /mnt/freenas cifs credentials=/home/username/freenascreds,vers=3.0,iocharset=utf8,sec=ntlm 0 0
 
Joined
Nov 21, 2019
Messages
1
For any who still may find this. i had the same issue only in my case it was a raspberry pi with a synology.
Enable SMB3 on my synology did the trick
 
Top